Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had a whole line of messes with java and .jar files. I've tried both OpenJDK (from software installer) and about three repositories for Sun.

/Desktop# java -jar -Xmx1024m ss.jar
Exception in thread "main" java.awt.HeadlessException
            at         java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:173)
            at java.awt.Window.<init>(Window.java:476)
            at java.awt.Frame.<init>(Frame.java:419)
            at java.awt.Frame.<init>(Frame.java:384)
            at javax.swing.JFrame.<init>(JFrame.java:174)
            at org.powerbot.bd.<init>(Unknown Source)
            at org.powerbot.Boot.main(Unknown Source)

Two separate errors:

~/Desktop# ./ss.sh
[SEVERE] org.server.Boot: Default heap size of 490m too small, restarting with 768m

and about 30 different crashes were it just "aborts" with a huge file dump.

Each time I've tried something a little different, whether it be updating Java or just changing -Xmx1024 to -Xmx1024m to get rid of the heap.

Personally I think it has something to do with OpenVZ, but Google hasn't saved me this time, I need someone who can get to the bottom of my problem.

java -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

is my current install.

Running ss.sh gives me: (I'd post the entire log but its long)

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGILL (0x4) at pc=0x00002b14278e6fa0, pid=9301, tid=47365590714112
#
# JRE version: 6.0_26-b03
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.1-b02 mixed mode linux-amd64     compressed oops)
# Problematic frame:
# C  [ld-linux-x86-64.so.2+0x14fa0]  _dl_make_stack_executable+0x2b50
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

I'm willing to let someone who knows what they are talking about view it and try and sort this out. Any help would be appreciated, I've about pulled all my hair Googling to no avail.

share|improve this question

2 Answers 2

I had a similar problem and could fix it.

Not sure what the problem was, but here is what worked for me:

After several tries I could fix the issue myself. What worked for me was to uninstall all openjava6 and dependencies via dpkg and install openjava7. That left me without javaws and the plugins. So I installed sunjava7 64 Bit as described here http://brunoreis.com/tech/intalling-java-ubuntu-natty/

Now everything is working fine for me.

share|improve this answer

I also had a the following exception while running jprofiler:

java.awt.HeadlessException
    at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:173)

Using /usr/lib/jvm/java-6-openjdk on Ubuntu 12.04 32-bit. I installed VisualVM from the "Ubuntu Software Update" which installed a whole lot of dependencies. One of them fixed the problem.

Installed dependencies:

bamfdaemon 0.2.118-0ubuntu0.2
desktop-file-utils 0.20-0ubuntu3
gnome-menus 3.4.0-0ubuntu1
hicolor-icon-theme 0.12-1ubuntu2
man-db 2.6.1-2
fontconfig 2.8.0-3ubuntu9
libhamcrest-java 1.1-8
junit4 4.8.2-2
libequinox-osgi-java 3.7.2-1
libfelix-framework-java 4.0.1-1
libfelix-main-java 4.0.1-2
xorg-sgml-doctools 1:1.10-1
x11proto-core-dev 7.0.22-1
libice-dev 2:1.0.7-2build1
libjna-java 3.2.7-4
libswing-layout-java 1.0.4-2
libpthread-stubs0 0.3-3
libpthread-stubs0-dev 0.3-3
libservlet2.5-java 6.0.35-1ubuntu3
libsm-dev 2:1.2.0-2build1
libxau-dev 1:1.0.6-4
libxdmcp-dev 1:1.1.0-4
x11proto-input-dev 2.1.99.6-1
x11proto-kb-dev 1.0.5-2
xtrans-dev 1.2.6-2
libxcb1-dev 1.8.1-1
libx11-dev 2:1.4.99.1-0ubuntu2
libx11-doc 2:1.4.99.1-0ubuntu2
libxt-dev 1:1.1.1-2build1
ttf-dejavu-extra 2.33-2ubuntu1
icedtea-netx-common 1.2-2ubuntu1
openjdk-6-jre 6b24-1.11.3-1ubuntu0.12.04.1
libatk-wrapper-java 0.30.4-0ubuntu2
javahelp2 2.0.05.ds1-6
libnb-platform12-java 6.9-0ubuntu2
icedtea-netx 1.2-2ubuntu1
openjdk-6-jdk 6b24-1.11.3-1ubuntu0.12.04.1
visualvm 1.3.2-0ubuntu2.1
libatk-wrapper-java-jni 0.30.4-0ubuntu2
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.