Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I only just installed Ubuntu 11.10, so excuse me if this question is silly ;-)

I have a Fujitsu Esprimo Mobile V655, nvidia 8200 graphics, and recently installed Ubuntu 11.10 using wubi. I had to modify booting commands to include nomodeset; otherwise Ubuntu would not boot.

Now I did set my screen resolution to 1280 x 720, which is the correct resolution for this screen. Still, the display seems imperfect. The font sizes seem unnatural(too large / stretched) and text is quite blurry (especially in Firefox).

Could it have something to do withe the nvidia graphics driver and/or the nomodeset parameter? How can I fix this?

Update:

I used jockey-gtk to update nvidia to the current version. This improved the resolution dramatically (no blurriness, fonts are good). It also means that I no loger need to include nomodesetin the boot commands.

However, other problems were brought up by this. It seems that certain files cannot be accessed - icon (images) are missing, some task bars are completely unstyled (grey, block-form, win97 style).

I also get this error message(roughly translated from German, so may be slightly different from actual) every time I reboot: Could not apply the stored configuration for the monitor: none of the chosen modi is compatible with the available modi.

I have tried nvidia-xconfig, unity --reset , no improvements.

Can anyone help, please?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Execute the Jockey application (jockey-gtk from command line) that will propose you an updated Nvidia driver that may solve your problems. Choose nvidia-current to use the most stable version.


After doing this it may be helpful to save and then replace your /etc/X11/Xorg.conf file.

First save your old config file with:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

Then:

sudo nvidia-xconfig

After that please reboot.

(Instructions below the line are from the follow-up comments).

share|improve this answer
    
OK so I got mixed results here. The resolution is actually better now (fonts look better, screen less blurry) but instead other graphics are messed up (display windows and task bars look block-y and are grey, like win97 style ^^). I also got the error message the saved display configuration could not be applied. (...) None of the chosen modi is compatible with the available modi (...) Do you have any other suggestions, or how can I fix this? –  FSchmidt Mar 25 '12 at 19:11
    
gives the error: fs@ubuntu:~$ nvidia-xconfig Using X configuration file: "/etc/X11/xorg.conf". VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf. Device section "Default Device" must have a Driver line. ERROR: Unable to write to directory '/etc/X11'. –  FSchmidt Mar 25 '12 at 19:29
    
that gives the same error –  FSchmidt Mar 25 '12 at 19:32
    
ok, do the following: 'sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old' and then 'sudo nvidia-xconfig'. –  yossile Mar 25 '12 at 19:34
    
alright, that gave me a warning, but no error. will reboot now and see what happens. –  FSchmidt Mar 25 '12 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.