Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the Samsung CLX-3185 printer/scanner. The printer-part works fine using 3175 drivers found by (Xubuntu/XFCE) printer setup wizard. However it does not seem to recognize the scanner part. Xsane does not find the scanner. Is there a setup HOWTO for this anywhere that I could use?

share|improve this question
up vote 3 down vote accepted

Instructions how to set-up samsung CLX-3185FW.

Source: baltas125@ubuntuforums. Originally taken from: bchemnet.

From the 1st link:

After executing instructions I have successfully installed CLX-3185FW over the network. It prints and scans over the network. I have made it on Ubuntu 11.10, 32bit.

Before installing you MUST REMOVE any other previously installed drivers for Samsung.

Step 1 (edit sources):

sudo gedit /etc/apt/sources.list

Add lines:

#samsung drivers
deb debian extra

Step 2 (install authentication key) :

wget -O - | sudo apt-key add -

Step 3 (update sources):

sudo apt-get update

Step 4 (install packages):

Open ubuntu software center and install one by one all packaged that start with " samsungmfp-", excepting:

  • first install packages which do not have the word "legacy";
  • do not install packages which offer you to remove any other packages;
  • Do not install "samsungmfp-parallel" it should only be installed if your printer is actually connected via a parallel port;

Step 5a (check if you are in lp group). Run in Terminal: cat /etc/group | grep lp

If your account name is next to lp, everything is ok, else add yourself to lp group, e.g. execute Step 5b.

Step 5b (add yourself into lp group if needed):0 sudo usermod -a -G lp USERNAME

( more information about groups:

That's it! Now you can search for your printer in network and add it as clx-3180 series and it will work.

P.S. Previously I have made some changes to some files. But I do not know if it has any impact. If you have executed the five step above and still no luck, try making those changes:


lines added

#Samsung CLX-3170fn & CLX-3175FW
usb 0x04e8 0x342a

In ...


lines added:

#Samsung CLX-3185FW
usb 0x04e8 0x343d

In ...


lines added:

# Samsung CLX-3185FW
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="343d", ENV{libsane_matched}="yes"
share|improve this answer
Thank you! This has worked for me as well. – wilx Mar 25 '12 at 16:12

here's some feedback:

  • I installed the Unified Linux Driver provided by Samsung (german manual providing useful links. The Samsung site has problems atm...). That made the printer work, but not the scanner

  • I hadn't installed xsane then, so I did sudo apt-get install xsane. xsane didn't find the scanner

  • I modified xerox_mfp.conf and 40-libsane.rules as described above, it should also work with the vendor and product ID of other mfp's you find using lsusb.

now the mfp works fine. thank you for the solution(s)!

btw: I'm with a CLX-3185 -> no netdiscovery required.

share|improve this answer

I had the "Samsung Unified Linux Driver" and "Xsane" installed already and the printer worked well. Only the scanner was not found. After adding following entry in /etc/sane.d/xerox_mfp.conf the scanner was found:

#Samsung CLX-3180

PS: I got that hint from

share|improve this answer
In the link you provided it says: "the IP address of course is just an example and should be replaced with the correct address". Instead of this you used "tcp". Please correct your answer. – karel Jul 24 '13 at 6:10

The model number Samsung CLX-3185.

Method 1:

You may refer to the below links and use the troubleshooters. Check if it lists and helps resolve any issues: Open the Printer troubleshooter:

Method 2:

You may check if you have the latest drivers installed for the device. You may refer to the below link for getting the latest drivers and check.

Samsung CLX-3185 Driver

share|improve this answer
Welcome to AskUbuntu! Your second link for Method 2 doesn't link to any Linux drivers so isn't really relevant to Ubuntu, you may want to post a different link. – Oyibo Oct 6 '12 at 10:35

Now there is great installations in Samsungs website;

Use this install and everything works OK!

Verify that you have permission to the sane group as well and after change please logout!

share|improve this answer

WHOA HAUS!!! Check it out. You don't need all that stuff. Add the repo, apt-get update, and install these 2 bits... samsungmfp-scanner samsungmfp-netdiscovery

That's all you need.. at least for Ubuntu 12.04 that is all you need. I successfully printed a test page and scanned a document.

share|improve this answer
What repo do yo mean? – wilx Nov 12 '12 at 6:39
Ok, I have figured out that you likely mean this one: How trusted is it? I am not inclined to install some random person provided binaries. – wilx Nov 12 '12 at 6:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.