Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Libreoffice 3.5 from PPA, but this problem appears:

ERROR: unopkg cannot be started. The lock file indicates it as already running. If this does not apply, delete the lock file at:
/var/lib/libreoffice/share/prereg/.lock
dpkg : erreur de traitement de /var/cache/apt/archives/python-uno_1%3a3.5.1-1ubuntu1~oneiric1_i386.deb (--unpack) :
 subprocess new pre-installation script returned error exit status 1
Treatment of deferred stock (« triggers ») for « libreoffice-common »...
Errors were encountered while processing :
 /var/cache/apt/archives/python-uno_1%3a3.5.1-1ubuntu1~oneiric1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
    
Hi, could you please edit your question add the full error message you get? Also, what is the PPA you're using to get LibreOffice? –  Alexandre Mar 25 '12 at 0:43
    
done,waiting for your answer :) –  khaled Mar 25 '12 at 1:16

1 Answer 1

up vote 1 down vote accepted

Seems like a bug, as described here.

According to that report, you should delete the lock file then proceed with install. Open a terminal and type:

sudo rm /var/lib/libreoffice/share/prereg/.lock
sudo apt-get -f install

And packages should be fixed.

share|improve this answer
    
problem solved,thank you –  khaled Mar 25 '12 at 11:58
    
@khaled great! If my answer led you to the solution, please mark my answer as the right one. Cheers! –  Alexandre Mar 25 '12 at 23:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.