Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to install the ubuntudico dictionary. I found it here. Downloaded the deb from the link provided there. I get an error (similar to the one I posted in a separate question that maybe could be unified with this one).

“Dependency is not satisfiable” error when trying to install ubuntudico

What is it to be done? What should I add to the repository?

When trying to install gambas2-gb-qt-kde i get the following: enter image description here

I don't seem to find kdelibs4c2a for my architecture. I have Xubuntu 11.10. Universe is enabled.

At this page I found that the requested environment is:

(k)(edu)Ubuntu 8.04 and above

Debian 5.0.4 and above

(Does this means that the dictionary is accessible only from kubuntu/edubuntu?)

And that the needed dependencies are:

gambas2-runtime (>= 1.9.48)

gambas2-runtime (<< 2.90)

gambas2-gb-qt (>= 1.9.48)

gambas2-gb-qt (<< 2.90)

gambas2-gb-form (>= 1.90.1)

gambas2-gb-form (<< 2.90.0)

gambas2-gb-net (>= 1.9.48)

gambas2-gb-net (<< 2.90)

gambas2-gb-qt-kde (>= 1.9.48)

gambas2-gb-qt-kde (<< 2.90)

gambas2-gb-qt-kde-html (>= 1.9.48)

gambas2-gb-qt-kde-html (<< 2.90)

But gambas2-gb-qt-kde and gambas2-gb-qt-kde-html are not available in Synaptic.

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

It looks like the package gambas2-gb-qt-kde has been removed from the repos starting in Oneric. It is still available for Natty and you may get some results by installing the Natty Universe repository and installing it from there. I went and did that and I found that one of the dependencies depends on something from natty main as well, so you'll need to add the following four items to /etc/apt/sources.list

deb http://us.archive.ubuntu.com/ubuntu/ natty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ natty universe
deb http://us.archive.ubuntu.com/ubuntu/ natty-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ natty-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ natty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ natty main restricted
deb http://us.archive.ubuntu.com/ubuntu/ natty-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ natty-updates main restricted

Then you'll download the deb for ubuntudico2 from the link you provided and run the following:

sudo apt-get update
sudo dpkg -i ubuntudico2.deb
sudo apt-get install -f

And then it will install. I would recommend removing the extra natty repos after that to prevent issues with packages later on.

share|improve this answer
add comment

It is along the same lines as your last question. Last time, you needed to enable a repository in order for apt to find the package needed. Think of a repository as a large phone book for programs (which are placed in bundles called packages). What apt is telling you is that it cannot find the package in any of the repositories it is aware of.

There are two ways to fix this. Either install a repository that has that package (if you are aware of one) or find the package on your own and install it.

Doing as search at http://packages.ubuntu.com indicates that the needed package is in the universe repository for several versions of Ubuntu (here). You can either download it from there or enable the universe repository in the same way you enabled the repository from the other question.

Using a repository is preferred, because you get automatic updates.

share|improve this answer
    
Universe was enabled in Synaptic/Settings/Repositories/Ubuntu Software. I have a general idea on repositories etc, maybe you would guide me a few more steps, as I assume I need a certain version (that is at least 1.9.48) of 'gambas2-gb-qt-kde'. But I cannot find it in the list to install when I put 'gambas' in Synaptic. At the address you gave me there seems to be no version of that one for Oneiric (I have Xubuntu 11.10) but anyway I tried the Lucid version as well as others I found searching and all give me another similar error concerning kdelibs4c2a (>= 4:3.5.9). I added screenshot of that. –  cipricus Mar 26 '12 at 6:24
    
I have updated the question –  cipricus Mar 26 '12 at 12:30
1  
I think your problem is that you have an XFCE based desktop but are attempting to install KDE oriented front end programs (see all the references to qt, kde, k-whatever). You might want to consider installing KDE as an alternative to XFCE (you can switch at login) and see if that satisfies your dependencies. –  Huckle Mar 26 '12 at 22:18
    
In fact, I would bet that all of the needed packages are located in the same repository that likely wasn't installed in Xubuntu but is in Kubuntu. Try to see if you can get a copy of /etc/apt/sources.list from Kubuntu and compare with your own. –  Huckle Mar 26 '12 at 22:20
    
i do have kde installed thanx - i'll try that –  cipricus Mar 27 '12 at 18:46
show 6 more comments

Dependency is not satisfiable see : http://forum.ubuntu-fr.org/viewtopic.php?pid=6850971#p6850971

Thanks Salamandre

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.