Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think this problem might be related to this one:

Failing to recover from hibernate

Basically, as soon as ive installed ubuntu, using the automatic partitioning, if i run gparted and look at my disk partitions, my swap space is displayed as unknown, with an exclamation mark next to it:

Error image

Ok, next step, i manually assign the 'unknown' section to be a swap partition, and attempt to hibernate. When i switch my system back on, it runs as described in the link above, failing to restore from hibernate. When i run gparted again after its restarted, the swap partition is back to 'unknown'. Any idea whats going on here?

share|improve this question
    
So if I understand correctly, everytime you restore from hibernation, then the swap partition becomes raw? –  Manish Sinha Mar 24 '12 at 20:20
    
yep, every time i attempt to hibernate –  richzilla Mar 24 '12 at 22:50
    
I am not sure why this is happening. The closest I could find was this on Unix StackExchange –  Manish Sinha Mar 25 '12 at 11:09

2 Answers 2

If you've chosen to encrypt your user-directory during the installation, Ubuntu will automatically encrypt your swap. This could be the Problem in this case. You can check your /etc/fstab for the device that is mounted as swap. If it's something like /dev/mapper/cryptswap1 your swap is encrypted and hibernate can't work.

share|improve this answer

https://bugs.launchpad.net/ecryptfs/+bug/432785

share|improve this answer
    
Can you state whether there is a workaround for the OP? –  hexafraction Aug 16 '12 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.