Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install glchess in Synaptic

glchess install

I get this error error

At a certain time I installed the Gnome desktop and a lot of games that came with it and then uninstalled the games. Now I want chess back. When I downloaded the deb file and tried to install it in Gdebi I got a similar error: install error glchess

What should I change in repositories?

share|improve this question
    
can you pastebin.com the output of sudo apt-get update && sudo apt-get upgrade as well as sudo apt-get install -f –  fossfreedom Mar 24 '12 at 20:12
    
pastebin.com/3DFQ9uGC –  cipricus Mar 24 '12 at 20:18

2 Answers 2

up vote 5 down vote accepted

From your pastebin it looks very much like you have not got the updates repository enabled

enter image description here

Tick this option shown - the refresh your installation before install pyChess

sudo apt-get update && sudo apt-get upgrade
share|improve this answer
    
indeed it was not checked !! (i guess i was trying to avoid the the repeated upgrade announcements). thank you. maybe question should be edited to become more inclusive and useful –  cipricus Mar 24 '12 at 20:41
    
by the way, may i know what image editor you used to create your illustrative image above? –  cipricus Mar 24 '12 at 20:44
    
@cipricus He probably used shutter - its in the repositories. –  jrg Mar 24 '12 at 20:47
    
its a screengrab from shutter –  fossfreedom Mar 24 '12 at 20:47
sudo apt-get build-dep glchess
share|improve this answer
    
would that work for other programs? i got my answer for this one but now i have a similar issue with installing a dictionary (ubuntudico), which i cannot install from deb because of a similar error –  cipricus Mar 24 '12 at 22:34
    
It worked for me while I was having having the similar situation. Maybe it can work –  Anurag Sharma Mar 24 '12 at 22:43
    
for ubuntudico2 it doesn't work. for chess i already solved it as seen in another answer –  cipricus Mar 24 '12 at 22:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.