Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't copy files to my memory card.

When i copy there is a error message and it says read-only file system.

But, i can copy file from the card.Can any one please help me.

I am using ubuntu 11.10.

share|improve this question
    
I think "Ubuntu 11.10" has little relevance, I have 13.10 and the same problem occurs. –  Yanick Rochon Nov 14 '13 at 13:23

2 Answers 2

up vote 0 down vote accepted

I think memory is locked on its adapter else formatting the memory would repair it

share|improve this answer
    
thanks a lot man.....it really works.. –  Yahya Mar 25 '12 at 16:36
    
what works? I have the same problem and this answer tells me nothing. I can use GParted to format the device, and play with it's partition, GParted never complains. But Nautilus whines about the device being read-only when I copy files unto it... yup. –  Yanick Rochon Nov 14 '13 at 13:21

If these information by wu-lee that can be helpful to you:

"Firstly, make sure the memory card hasn't got the "lock" tab engaged! This is a plastic sliding thing on the side of the card. Sometimes it is loose enough that pushing the card into the slot engages it. To allow writing, the tab should be pushed into the forward position, nearest the contacts.

Now make sure you have write permissions for the device. The memory card device is /dev/mmcblk0 (other devices will be different), so try this:

$ ls -l /dev/mmcblk0
brw-rw---- 1 root disk 179, 0 2010-08-04 10:35 /dev/mmcblk0

This shows it's readable and writable (rw) by the root user, and the disk group. I'm not root, so am I in the disk group?

$ groups
nick adm dialout cdrom plugdev lpadmin admin sambashare

Nope. So how do I become a member? You can set your user's group membership in Applications->settings->sytem settings->advanced->user management (KDE) or in System->Admin->Users and Groups (Gnome). Or you can do it with the command:

sudo usermod -a -G disk $USER

Where $USER is your user name.

Now check it worked - "disk" should be listed in your group membership, like this:

$ groups
nick adm disk dialout cdrom plugdev lpadmin admin sambashare

Typically group membership won't get updated until you open a new log-in shell or start a new session. So you may need to log off and on again, or open a login shell like this:

$ su - $USER -c bash

Now, as a member of the "disk" group, you should have write access to the memory card.

Source

share|improve this answer
    
it is not working yet.......... –  Yahya Mar 24 '12 at 14:56
    
What about a chmod 777 to the directory where the SD Card is mounted? –  LnxSlck Mar 24 '12 at 14:58
    
Please update your question and tell us what file system is on the SD card and permissions of the mount point (should be in /media) . A file system also gets mounted ro when there is a problem, so unmount the sd and try running fsck. –  bodhi.zazen Mar 24 '12 at 15:17
    
Man great it is working now.Thank you so much. –  Yahya Mar 25 '12 at 15:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.