Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10. In my dorm I have to change network configuration and then if it is successful, I have to enter a user name and password for wired internet connection. Anyway, I had many attempts but I couldn't achieve this, please look at my steps and tell me if there is something wrong. At the end there is an error, but I really don't have any idea about this error.

$ cat /etc/network/interfaces
auto eth0
iface eth0 inet static
address 172.030.014.038
netmask 255.255.255.252
network 192.168.2.0
broadcast 192.168.2.255
gateway 172.030.014.038

$ cat /etc/resolv.conf
nameserver 010.050.001.001
nameserver 010.050.001.002

$ /etc/init.d/networking stop
* Deconfiguring network interfaces... [ OK ]

$ /etc/init.d/networking restart
* Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
* Reconfiguring network interfaces... 
172.030.014.038: Unknown host
ifconfig: `--help' gives usage information.
Failed to bring up eth0

Note: IP-address, netmask, gateway, Preferred DNS server and Alternate DNS server are given by the management of Dorm. It was very easy in windows but I couldn't achieve in Ubuntu. I also tried to edit from "Edit Connections" but the save button is not enabled and I cannot save it.

share|improve this question
    
hmm, that network and broadcast, don't match with the address and the gatway. Are you sure this is the configuration suggested for your connection? –  kmassada Jul 13 '12 at 18:05
    
your ip configurations are completely wrong, this couldn't have worked on windows,ever. –  fromnaboo Jan 31 '13 at 20:28
add comment

3 Answers

I think you have to configure your VPN from network menu of Ubuntu. Because you have a user name and a password.

Before start, delete other configuration you have made earlier.

Click on network connection and select edit connections

Click on VPN tab. This window will appear

enter image description here

Fill up the empty box with exect info.

Connection name : myvpn

Cheeck Connect automatically

Gateway: 172.030.014.038

User Name:

Password: **

NT Domain : (Your network address 192.168.2.0)

Now click on IPv4 tab

Method: Automatic (VPN) address only

DNS servers: 010.050.001.001

Search domains : 010.050.001.002

Now click Save.

It should connect now automatically.

You can connect/disconnect to your network by command line

vpnc-connect myvpn to connect vpnc-disconnect myvpn to disconnect.

share|improve this answer
add comment

You have a few mistakes in your network configuration:

  1. Your Gateway is the same as your IP address.
  2. Your Network is mistaken (out of range).
  3. Your Broadcast is mistaken (out of range).

Ask for the correct values from your Dorm's support. Mind that Network and Broadcast aren't mandatory for the network connection to work, so you might just delete them from that configuration file, but still, your Broadcast cannot be the same as the Address.

share|improve this answer
add comment
  1. you don't need to type a 0, in front of a 2 digits value.

example: address 172.30.14.38 instead off 172.030.014.038

  1. the netmask may be right, but I doubt it. i have a hunch that it should be 255.255.255.0 (to match with the atempt of the network address that you have written)

  2. the network will have to look alike to the address values, but differ on the last field, like this: 172.30.14.0. this is not mandatory, you can skip the network line from the file.

  3. with this configurations, the broadcast will be: 172.30.14.255.this is not mandatory, you can skip the broadcast line from the file.

  4. the gateway might be: 172.30.14.1

  5. I don't know if your DNS values are corect, but I know the google public dns: 8.8.8.8.

Write this in the /etc/network/interfaces file:

auto eth0
iface eth0 inet static
    address 172.30.14.38
    netmask 255.255.255.0
    gateway 172.30.14.1

And in the /etc/resolv.conf write this:

nameserver 8.8.8.8

Now reboot the network inteface: sudo /etc/init.d/networking restart

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.