Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I've been fighting these wireless drivers for a few days and just recently i noticed that the model the Wireless controller appears in lspci is different sometimes. This is the data i have after installing Ubuntu Server 64 bit

~# lspci -k 
....
04:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01) 
        Subsystem: AzureWave Device 1d89 
        Kernel driver in use: ath9k 
        Kernel modules: ath9k

ran some updates, restarted, all was good, all though it did say that linux-headers-server linux-image-server linux-server where beeing kept back.

After that i installed ubuntu-desktop (aptitude install ubuntu-desktop --without-recommends) restarted and not only is the wireless not working anymore, but the hardware is listed as a different card

~# lspci -k
....
04:00.0 Ethernet controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)

has no available drivers for it, still i tried to modprobe ath9k, they show up in lsmod as loaded, but still iw list shows nothing.

this is what it looked like before the ubuntu-desktop instalation

Wiphy phy0
    Band 1:
        Capabilities: 0x11ce
            HT20/HT40
            SM Power Save disabled
            RX HT40 SGI
            TX STBC
            RX STBC 1-stream
            Max AMSDU length: 3839 bytes
            DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 8 usec (0x06)
        HT TX/RX MCS rate indexes supported: 0-7
        Frequencies:
            * 2412 MHz [1] (14.0 dBm)
            * 2417 MHz [2] (15.0 dBm)
            * 2422 MHz [3] (15.0 dBm)
            * 2427 MHz [4] (15.0 dBm)
            * 2432 MHz [5] (15.0 dBm)
            * 2437 MHz [6] (15.0 dBm)
            * 2442 MHz [7] (15.0 dBm)
            * 2447 MHz [8] (15.0 dBm)
            * 2452 MHz [9] (15.0 dBm)
            * 2457 MHz [10] (15.0 dBm)
            * 2462 MHz [11] (15.0 dBm)
            * 2467 MHz [12] (15.0 dBm) (passive scanning)
            * 2472 MHz [13] (14.0 dBm) (passive scanning)
            * 2484 MHz [14] (17.0 dBm) (passive scanning)
        Bitrates (non-HT):
            * 1.0 Mbps
            * 2.0 Mbps (short preamble supported)
            * 5.5 Mbps (short preamble supported)
            * 11.0 Mbps (short preamble supported)
            * 6.0 Mbps
            * 9.0 Mbps
            * 12.0 Mbps
            * 18.0 Mbps
            * 24.0 Mbps
            * 36.0 Mbps
            * 48.0 Mbps
            * 54.0 Mbps
    max # scan SSIDs: 4
    max scan IEs length: 2257 bytes
    Coverage class: 0 (up to 0m)
    Supported Ciphers:
        * WEP40 (00-0f-ac:1)
        * WEP104 (00-0f-ac:5)
        * TKIP (00-0f-ac:2)
        * CCMP (00-0f-ac:4)
        * CMAC (00-0f-ac:6)
    Available Antennas: TX 0x1 RX 0x3
    Configured Antennas: TX 0x1 RX 0x3
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * WDS
         * monitor
         * mesh point
         * P2P-client
         * P2P-GO
    software interface modes (can always be added):
         * AP/VLAN
         * monitor
    interface combinations are not supported
    Supported commands:
         * new_interface
         * set_interface
         * new_key
         * new_beacon
         * new_station
         * new_mpath
         * set_mesh_params
         * set_bss
         * authenticate
         * associate
         * deauthenticate
         * disassociate
         * join_ibss
         * join_mesh
         * remain_on_channel
         * set_tx_bitrate_mask
         * action
         * frame_wait_cancel
         * set_wiphy_netns
         * set_channel
         * set_wds_peer
         * connect
         * disconnect
    Supported TX frame types:
         * IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
         * managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
         * AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
         * AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
         * mesh point: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
         * P2P-client: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
         * P2P-GO: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
    Supported RX frame types:
         * IBSS: 0x00d0
         * managed: 0x0040 0x00d0
         * AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
         * AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
         * mesh point: 0x00b0 0x00c0 0x00d0
         * P2P-client: 0x0040 0x00d0
         * P2P-GO: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
    Device supports RSN-IBSS.

What's with the hardware change? If it has 2, how can i make the AR9285 always load and disable AR5008, or, is it the same and it's just showing it different? :|

Oh and I've tried this on Ubuntu 10.04 server, xubuntu 12.04, ubuntu 12.04 desktop and server.

Thanks in advanced.

-- Here's some more info, i have it setup in 2 hard drives, 1 works and the other one i'm using to figure it out

The one that works...

# lshw -class network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 06
       serial: 54:04:a6:a3:3b:96
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.2.147 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:43 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlan0
       version: 01
       serial: 74:2f:68:4a:26:73
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.2.0-18-generic-pae firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 memory:fea00000-fea0ffff

Here's where it doesn't

# lshw -class network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 06
       serial: 54:04:a6:a3:3b:96
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.2.160 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:43 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR5008 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:fea00000-fea0ffff

Update

I've noticed that if i blacklist the ath9k and ath9k_common modules lspci gives me the AR9285, but then I need to modprobe ath9k for it to work, does this make any sense? If so, why?

Update

Messed around with some other packages this morning and it was listing the AR5008, reinstalled some drivers and now it's AR9285 -.-

Update

here is /var/log/udev , right now it's saying it's AR5008 found some reference to that somewhere in the log - PCI_ID=168C:FF1C

Update

@aking1012 ath5k are never loaded, tried the blacklist though, but still no. blacklisting ath9k and ath9k_common sometimes do it, but then with no other changes it stops having any affect

These are the modules i'm playing with the blacklist

blacklist ath5k
blacklist ath9k
blacklist ath9k_common

blacklist eeepc_wmi
blacklist asus_wmi
blacklist ath_pci
blacklist wmi

Update

This seems to be working so far on 32 bit, if so, thanks @david6

Update

@jrg @david6 Installed Video drivers and it's broken again

Update

Not that it's relevant to Ubuntu, but I just got the same thing running windows on it, AR5008... restarted AR9285, one worked, the other didn't ... looking more like a hardware issue now

share|improve this question
    
Some more info on this, compiled my own kernel, removed support for all ATH5K + the hardware, installed it, rebooted and i got the correct card, rebooted again and i saw the AR5008 again :| –  geermc4 Mar 25 '12 at 3:01
    
Are you using ndis-wrapper , a kernel driver or some different driver? sourceforge.net/apps/mediawiki/ndiswrapper/… –  jippie Apr 4 '12 at 21:15
    
I have tried both with just what ever ubuntu installs by default and installing linuxwireless.org/en/users/Drivers/… –  geermc4 Apr 4 '12 at 22:21
1  
Possible solution: bugs.launchpad.net/ubuntu/+source/rfkill/+bug/900030/comments/2 which may resolve this for you. –  david6 Apr 7 '12 at 0:49
1  
@david6 Please add that as an answer. Thanks! –  jrg Apr 11 '12 at 22:37
show 4 more comments

closed as too localized by Jorge Castro, fossfreedom May 31 '12 at 12:28

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

found a link somewhere that showed it is a coexist problem, to solve:

Create a /etc/modprobe.d/iwl.conf

that contains (first one worked for me):

#!/bin/sh
options iwlagn bt_coex_active=0

or

#!/bin/sh
options iwlwifi bt_coex_active=0
share|improve this answer
add comment
up vote 0 down vote accepted

It was a bad card :(, lots of time spent on it, tried with 4 others of the same model and none had the same problem.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.