Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 11.10 on Dell XPS 15z. Somebody know why kernel does not load the latest firmware for wifi Intel Centrino Advanced-N 6230.

$ modinfo iwlagn |grep iwlwifi-6000

firmware:       iwlwifi-6000g2b-5.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6000-4.ucode

In package linux-firmware there is latest version (iwlwifi-6000g2b-6.ucode)

$ dpkg -L linux-firmware | grep iwlwifi-6000

/lib/firmware/iwlwifi-6000-4.ucode
/lib/firmware/iwlwifi-6000g2a-5.ucode
/lib/firmware/iwlwifi-6000g2b-5.ucode
**/lib/firmware/iwlwifi-6000g2b-6.ucode**
share|improve this question
    
In 12.04 it works correct: $ modinfo iwlwifi |grep iwlwifi-6000 firmware: iwlwifi-6000g2b-6.ucode firmware: iwlwifi-6000g2a-5.ucode firmware: iwlwifi-6000-4.ucode –  grzeh Jul 20 '12 at 17:20

1 Answer 1

I did a test with this issue and found following:

  • rename firmware usal loaded:

    mv /lib/firmware/iwlwifi-6000-4.ucode /lib/firmware/iwlwifi-6000-4.ucode_orig
    mv /lib/firmware/iwlwifi-6000g2b-6.ucode /lib/lib/firmware/iwlwifi-6000-4.ucode
    
  • unload/load module

    sudo modprobe -r iwlwifi
    sudo modprobe -v  iwlwifi
    
  • Look what firmware loaded was found:

    dmesg | grep iwl | grep firm
    

    [ 4171.852769] iwlwifi 0000:03:00.0: Driver unable to support your firmware API. Driver supports v4, firmware is v6.

share|improve this answer
    
Thank you for answer. I have not module "iwlwifi", so I have used "sudo modprobe -r/-v iwlagn". But I still have massage "[ 2789.707813] iwlagn 0000:03:00.0: loaded firmware version 17.168.5.1 build 33993". –  grzeh May 18 '12 at 6:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.