Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the error i got while clicking on the videos on the right pane.

"Could not open location; you might not have permission to open the file."

I had a inspection on totem plugs and found that there is no youtube.py in this directory (/usr/lib/totem/plugins/youtube/)

share|improve this question
    
How did you install this plugin. I can't find a youtube plugin for totem in the Software Centre. –  dv3500ea Nov 5 '10 at 13:47
    
it works for me, and I have also no youtube.py in that directory. You could try reinstalling totem-plugins –  david Nov 5 '10 at 14:02
2  
@dv3500ea: It comes with 'totem-plugins'. –  aneeshep Nov 5 '10 at 15:33
    
I can also confirm that it works fine. –  TheX Nov 5 '10 at 16:55
    
you can answer you own question and mark it solved you know... –  RolandiXor Nov 6 '10 at 2:55

4 Answers 4

up vote 0 down vote accepted

Hi there is a updated package available from this ppa https://launchpad.net/~barcc/+archive/ppa. To install it from this ppa open a terminal and execute the following commands.

 sudo add-apt-repository ppa:barcc/ppa
 sudo apt-get update
 sudo apt-get upgrade totem

Hope this will help

share|improve this answer
    
Thanks man..,Great Fix –  Shameem Nov 6 '10 at 10:37

I think the problem is that YouTube made some changes in the site on July 22nd that affects all download extensions and plugins. Basically, is not allowing to get the videos using the old urls, so the player throws that error.

I suggest you try my extension FlashVideoReplacer. It allows to watch YouTube, Vimeo and Blip.tv videos using totem, gecko-mediaplayer, gxine, kaffeine, mozplugger, or xine plugins. The beast feature is that it replaces the video on site, so you don't need to start standalone players or download the video. There are limitations tho. It doesn't work on YouTube channels, just single video pages and flash needs to be installed to work.

The extension is for Firefox, but I'm working on versions for Opera and Chrome.

alt text

share|improve this answer
    
@GStreamer encountered a general supporting library error. –  Shameem Nov 6 '10 at 2:21
    
Now I got GStreamer encountered a general supporting library error –  Shameem Nov 6 '10 at 2:21
    
@user5213 Try this: ubuntuforums.org/showthread.php?t=766683 –  lovinglinux Nov 6 '10 at 2:49

Like lovinglinux says: this is probably because of a change on the YouTube site by Google. And I think the best solution would be to request a backport of that plugin from 10.10 to 10.04 (as it definitely works on 10.10).

share|improve this answer

I am having this same issue in 10.04

I installed the https://launchpad.net/~barcc/+archive/ppa repo, but the totem package seems too be the same version as in lucid updates.

I installed totem from the repo, but still same error with youtube.

If this works in 10.10, how do you get the backport.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.