Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to install Ubuntu 11.10 on a partition of a hard disk, but keep getting this error:

executing grub-install/dev/sda1 failed

Can't delete all partitions as there is important data on the other partitions.

share|improve this question
    
is this partition is a primary one ? –  eyadof Mar 22 '12 at 18:59
    
Is that the exact command you are using? –  Bruno Pereira Mar 22 '12 at 19:12
2  
grub-install/dev/sda1 is actually wrong, you need to add a space: grub-install /dev/sda1. Also you probably wanted to install it to sda, and not sda1, as the MBR sector, where grub gets installed is only one per drive. –  Rafał Cieślak Mar 22 '12 at 19:14
    
You may be experiencing this bug that affects many users: bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/976027 –  Enkouyami Jun 5 '12 at 17:38
    
related post: askubuntu.com/q/128937/62483 –  Lucio Mar 3 '13 at 15:50
show 1 more comment

closed as too localized by qbi, Mik, Seth, jrg Mar 3 '13 at 19:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Is there a reason why you want to install the MBR on /dev/sda1?
You should try with grub-install /dev/sda

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.