Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a remote system on which I defined two accounts - an administrator and a standard user. The machine was fallbacked from Unity to GNOME. I use vnc4server to remotely connect to the system, and RealVNC Viewer for the actual connection from my Win 7 laptop.

From the two accounts I started the servers as:

>> vnc4server -geometry 1440x900

I also have the following ~/.vnc/xstartup file in both accounts:

#!/bin/sh
# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
gnome-session --session=gnome-classic &
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &

Now, when I connect to the admin account, I get a desktop and can open a terminal to type my commands.

On the user account, however, I can do the same - but when I type the d key, the terminal minimizes, until I press the key again. What's going on here? How can I claim my d back?

EDIT: thanks to @zigg, I found the problem. I wonder, though, where does it inherited the "D" shortcut from? This is a fresh account and the changes I made were just to the .vnc file above???

share|improve this question

1 Answer 1

up vote 3 down vote accepted

On the user account, check the Keyboard control panel, under Shortcuts. "Minimize window" is set to "Disabled" on my system, but it may have accidentally been set to the letter d on your system.

If it is, you can hold down the mouse on that row until it says "New shortcut...", then press Backspace.

share|improve this answer
    
Yes, this led me to the problem! By default, I had just "D" in the "Navigation"->"Hide all normal windows" shortcut... changed it to Ctrl-Alt-D, like in the other account, and voila! –  ysap Mar 22 '12 at 18:09
    
This worked for me too, but I had to log out and log back in before the changes were in effect. –  dreamlax Mar 2 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.