Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two Ubuntu systems and in the course of changing configurations something has become muddled.

I have disabled Unity in favor of gnome shell, the older style display of the desktop. Then I installed xfce 4. Seemed everything would be working okay, and for the most part it does.

Except I noticed that on one system there's something else controlling settings.

On one, if I right click the desktop, I get the menu with the options:

open in new window 
create launcher... 
create url link... 
create folder... 
create from template ->  
open terminal here 
paste 
desktop settings... 
properties... 
applications ->

On system two, right clicking brings up the menu:

Create new folder
Create new document ->
organize desktop by name
keep aligned
paste
Change Desktop Background

Additionally, even though I set the background with the xfce settings manager, on system two that background will appear for a few seconds before it's replaced by something that looks like a background from Ubuntu's original desktop. And it's being controlled by what comes up with the "change desktop background" when right clicking, which isn't the xfce settings manager.

On the first system, that right click does bring up the xfce settings tool.

In short, something is controlling/overriding the xfce settings on machine two, but I can't find what file or configuration tool is doing it. How can I get system two to behave as system one, giving control of settings and configuration of X to XFCE's tools?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

XFCE uses more Gnome settings than we'd like to believe. Delete the following directories in your /home/bart directory:

.config
.gnome2
.cache

Log out and log back in. Your XFCE desktop should be set to post-install defaults.

share|improve this answer
    
I'll refrain from ranting as to why the .cache deletion fixed this months-long issue...but it did. –  Bart Silverstrim Mar 22 '12 at 17:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.