Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu using VirtualBox on Windows 7, and everything went fine. I'm trying to add new folders using the default file manager Nautilus, but:

Create New Folder

is disabled in any system folder. It works within my user folder though. Have I configured the virtual HDD incorrectly?

new folder

And here is my VirtualBox config:

  • SATA Controller
  • AHCI
  • Port Count: 1

enter image description here

share|improve this question

3 Answers 3

up vote 5 down vote accepted

Everything is fine with your installation. It is how it is supposed to be.

Ubuntu protects you from doing things that may be not such a good idea by allowing possibly dangerous actions only to the super user (su...do) "root" who has administrative permission. Creating files or folders outside of our home directory is one of those tasks. Installing software would be another example of what only a super user can do (this effectively keeps malware out).

As previous answers already showed it can very easily be done. Nevertheless I suggest you wait a bit, get familiar with the Ubuntu way of doing things, and you will find out that indeed creating files and folders outside our home directories is almost never needed.

By doing so Ubuntu will reward you with the joy of having a stable and easy to maintain system where everything stays at the place its supposed to be.

share|improve this answer

As you don't have permission to write to /usr/src the option to create folder within it is disabled.
You can do it in command line by executing the mkdir command as root sudo mkdir /usr/src/new_dir or run the file manager as root gksudo nautilus.

share|improve this answer
    
You shouldn't run graphical utilities with sudo, use gksudo instead (when using a gnome based desktop). –  tgm4883 Mar 22 '12 at 16:01

You are trying to create a folder where you do not have permission to do so. Try creating a folder inside your Home directory, that should work.

To create a folder in the directory in the screenshot, you will need to open a terminal. Change to that directory, then create the folder with the sudo command.

cd /usr/src/

sudo mkdir <NEWFOLDERNAME>

Here is some info on sudo in case you want to read up on that. https://help.ubuntu.com/community/RootSudo

share|improve this answer
    
In addition, you could start an instance of Nautilus (the file manager) with root privileges (alt-F2, gksudo nautilus), but note that this is VERY dangerous as you now have a GUI tool where a finger slip can cause catastrophic damage to your system files. –  Adrian Mar 22 '12 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.