Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As a newbie I seem to have messed up my upgrade leaving my system in a very unstable state.

I attempted an upgrade from 8.04LTS which ended in an error about libc and kernel upgrades. I tried to upgrade the kernel but am now unsure if that worked, because when I retried my dist-upgrade there was a lot of errors about pre-dependencies and leaving packages un-configured.

Now I have a system that answers almost every command with:

/lib/libc.so.6: version `GLIBC_2.8' not found (required by /lib/libselinux.so.1)

I probably should try a complete re-installation, but I'm investigating if there is any possibility of getting a working glibc so that I at least can have some commands working to ensure that my backups are recent etc. before doing the clean install.

not even 'ls' works without saying "glibc_2.8 not found".

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I would do everything from a Live session. Boot to the CD or USB and mount your disk and you should be able to check your backups (and pull out any files you haven't backed up). I'd suggest copying anything you value onto some sort of external media (eg an external USB disk or another computer over the network).

Once you're done there I'd reinstall a modern version of Ubuntu. Even if you'd rather stick with LTS releases, I'd go with 11.10 and update to 12.04 (an LTS) in April.

share|improve this answer
    
I'm going to try this. But first a disk image clone... –  Thomas Nilsson Mar 23 '12 at 11:34

There is not a straight-forward way of doing this. It will require live media and be highly situation dependent.

share|improve this answer
    
I really wanted to know if there was a way that I could figure out or fix this by overwriting, adding, changing some files or some such since not even 'ls' works without saying "glibc_2.8 not found". –  Thomas Nilsson Mar 22 '12 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.