Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed xmonad a couple of nights ago. Xmonad includes the files that you would need select it from GDM (e.g. /usr/share/applications/xmonad.desktop and /usr/share/xsessions/xmonad.desktop).

I tried starting xmonad via gdm and locked up X... (eventually even the virtual terminals locked up and I had to reboot the machine). The next time I started the machine I selected gnome instead of xmonad, it launched gnome-session, but tried to run xmonad instead of metacity as the desktop environment (this was entirely unusable). I moved the xmonad.desktop files in both /usr/share/applications and /usr/share/xsessions, now I have no desktop environment (which is slightly usable). How do I re-enable metacity?

share|improve this question

1 Answer 1

In a terminal,

sudo update-alternatives --config x-window-manager

will probably do the trick. Alternatively you can

sudo apt-get purge xmonad

and that should do the trick also.

share|improve this answer
    
I'll give it a shot when I get home. I was considering purging xmonad, but I would actually like to get it to work... –  Barton Chittenden Mar 22 '12 at 18:27
    
Hm... I ran that, but a) metacity was already selected and b) even re-selecting it didn't fix the problem. I can run metacity from a gnome-terminal, but that's a workaround, not a fix. –  Barton Chittenden Mar 22 '12 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.