Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I haven't been able to get 3d acceleration to work properly on my VBox guest, no matter what I do I always get fallback unity 2d mode, here's what I've tried:

  • Enabled "3d acceleration" on VBox settings, set video memory all the way to 128mb.
  • Installed vbox guest additions, checked to see if there was any guest additions pre-installed first, it didn't throw any errors
  • Enabled "Oracle VirtualBox Guest Additions for Linux Module" in "Additional Drivers"
  • Ran "unity --replace"

Nothing seems to work, I'm using VBox 4.1.10. The guest additions seem to work partially though, before I install them if I maximize my ubuntu guest window it doesn't resize up but after installing them the desktop does resize correctly but I'm stuck in unity 2d (I also tried installing gnome-shell and it also threw me in fallback mode)

Anyone knows what could be wrong? Thanks in advance!

EDIT: Looks like it's not a problem with Unity but VirtualBox, I tried with mint, arch and debian and all DEs switched me to fallback mode

share|improve this question

closed as off-topic by Seth Jun 24 '14 at 19:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

Just guessing: it may be an issue of your host graphics driver. Details? – Takkat Mar 22 '12 at 7:19
Maybe it will give you a direction - I noticed that when I run unity --replace within Unity2D I actually get Unity (problem is that I get both at the same time) – yossile Mar 22 '12 at 7:34
Well I have a geforce 8600 gt 1gb, it's not that great but it does render unity 3d if I install ubuntu as dual boot, I also ran "unity --replace" and the screen started to flicker, had to log off and back in to make it stop – javiervd Mar 23 '12 at 0:04
Are you still experiencing this problem? Have you tried a newer version of Ubuntu? – Seth Jun 24 '14 at 19:33

I have installed both Ubuntu 11.10 and 12.04 it doesn't need any additional settings as far as I recollect. So now the question is that have you tried the same ISO installer some where else. I doubt if the installer itself is not able to install required packages. Or try to update the system if you have not done it yet.

share|improve this answer
Updated everything but no luck yet, I'm not sure what's going on everywhere I look online says to just enable 3d acceleration and install guest additions but it doesn't work for me :( – javiervd Mar 23 '12 at 0:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.