Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 750GB hard disk with Windows 7 installed. So I shrunk the C: drive to about 80 GB, created two more partitions, one for data (about 615GB), one for ubuntu (30GB) (extended partition). I ran gparted, created a 8.5 GB swap partition inside ubuntu partition, and left whatever to ubuntu root partition. So I went to install ubuntu. After a few tries, everything worked. But now, I noticed some puzzling facts. Here are the output of a few commands:

$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda7              5333936   4472688    590300  89% /
udev                   4043640         4   4043636   1% /dev
tmpfs                  1621024       864   1620160   1% /run
none                      5120         0      5120   0% /run/lock
none                   4052552       200   4052352   1% /run/shm
/dev/sda4            599041020 213046820 385994200  36% /home

$ sudo parted -l
Model: ATA TOSHIBA MK7559GS (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  26.8GB  26.8GB  primary   fat32           hidden, lba
 2      26.8GB  105GB   78.4GB  primary   ntfs            boot
 3      105GB   137GB   31.5GB  extended
 5      105GB   114GB   8913MB  logical   linux-swap(v1)
 7      114GB   120GB   5549MB  logical   ext4
 8      120GB   128GB   8496MB  logical   linux-swap(v1)
 6      128GB   137GB   8496MB  logical   linux-swap(v1)
 4      137GB   750GB   613GB   primary   ntfs

In df output, / has only about 5GB, and in parted output, there are two more partions (number 6 and 8) of 8GB each. I don't remember I ever created them. What are they? Are these disk space being wasted? How can I reclaim them?

Help is greatly appreciated.

Thanks in advance.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Something there suggests to me that you created the partitions and picked one of the automatic options in the installer, which went on to further subdivide the space of a new partition. It's just a theory and I've no idea why there are three swaps.

This is the second post like this I've seen recently. There's rarely a good reason to set your own partitions; let the installer handle all that, that's what it's there for.

Personally if I'd just done this I'd boot back to the LiveCD, delete all the Linux partitions and ask the installer to just automatically install into the free space. I'd do this because installing Ubuntu takes about three seconds. Moving partitions around takes a lot longer and is much riskier.

share|improve this answer
    
You're right that I created the swap and root partitions. But I don't remember seeing any place the installation prompted me about repartition my hard disk. After all, what did the installation created these partitions for? Just sitting there for nothing? Can I remove those partitions (6 and 8) and expand my root partition without reinstall since I already did some setups in last a couple of days. –  G. He Mar 22 '12 at 0:15
    
I did more search and found another thread which is exactly the same problem I had. askubuntu.com/questions/85408/… I would consider this is a bug in the installer. –  G. He Mar 22 '12 at 0:24
    
You can resize. I suggest you keep the first swap (#5 in your list above) and nuke the second two and expand over those. Anything else might screw the boot order up. The Grub page has details on reinstalling the bootloader if you run into issues. –  Oli Mar 22 '12 at 0:31
    
Thank you very much. I would give this a try. Really appreciate your timely advices. –  G. He Mar 22 '12 at 0:37
    
I'm actually surprised the hibernate worked given the current swap situation. I have 8G memory, and the swap partition being used is only 7.9G. I would expect some problem with hibernate but it worked anyways. –  G. He Mar 22 '12 at 0:41
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.