Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been installing software packages from USC and I am getting the following error message. Worked fine one minute then the message below. Tried to search but couldn't find a solution Previously I was installing the sun-java6-jre package in terminal and had an connection outage and it didnt complete. I attempted an apt-get -f install with no success. i dont know what to try next. I'm relatively new to Linux. The answer provided with a similar question on this site didnt resolve the issue for meClick on this link

An unhandlable error occured There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

Details

File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 1092, in _simulate_helper return depends, self._cache.required_download, \

File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 235, in required_download pm.get_archives(fetcher, self._list, self._records) SystemError: E:I wasn't able to locate a file for the sun-java6-jre package. This might mean you need to manually fix this package.

Terminal Output Link http://dl.dropbox.com/u/48466855/Terminal%20output.odt

share|improve this question
    
please add to your question the terminal output to the following: sudo apt-get update && sudo apt-get upgrade –  fossfreedom Mar 21 '12 at 21:59
    
As requested: See output –  Stephen Myall Mar 21 '12 at 22:23
    
?? please put the results into your question or via pastebin.com –  fossfreedom Mar 21 '12 at 22:25
    
Thanks and apologies, Im new to this, I added a link from my dropbox but I will look at pastebin now –  Stephen Myall Mar 21 '12 at 22:44
    
pastebin.com/kJ6BRPtF –  Stephen Myall Mar 21 '12 at 23:02
add comment

1 Answer

up vote 1 down vote accepted

ok - you are using a PPA that when installing producing the following screen.

enter image description here

I looks like you closed this screen unexpectedly causing the package manager issues.

Restart the package installation via

sudo apt-get install -f

When you get to this screen, press the TAB key or possibly the arrow keys to navigate to the OK button. Press ENTER

This will allow your installation to complete successfully.

Note - this is not the recommended method to install Java.

The links below will explain the community accepted Java installation methods.

If you follow this, then first clean up your installation by removing the PPA.

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ferramroberto/java
sudo apt-get update && sudo apt-get upgrade

This should now report no more errors.

N.B. if you definitely want JRE 6 - just substitue the 1.7 reference with 1.6 in my answer.


Linked Question2:

  1. How to install Java?
  2. How can I install Oracle Java JRE 7?
share|improve this answer
    
Thanks I entered the first line (Command not found) pastebin.com/CAFyFDQz –  Stephen Myall Mar 21 '12 at 23:10
    
Unfortunately still an issue: pastebin.com/sgk9Q92Y –  Stephen Myall Mar 21 '12 at 23:17
    
when you do sudo apt-get -f install what is the output? –  fossfreedom Mar 21 '12 at 23:18
    
same error msg as my last paste, not our lucky night! –  Stephen Myall Mar 21 '12 at 23:31
1  
PROBLEM SOLVED Thank you for all your help. I will look at your answer above and purge then install Oracle –  Stephen Myall Mar 22 '12 at 0:05
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.