Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Lenovo X121e running Ubuntu 11.10, I find that both Nerworking and Wireless are disabled in Network manager's menu every time I boot the system.

This is a recent feature, it used to work.

share|improve this question

2 Answers 2

This is probably you did a hardware switch. This can be undone by pressing your wifi activator key. It differs on different computers. But to check, open your terminal crlt+alt+t. Then press rfkill list (Description of rfkill: rfkill - tool for enabling and disabling wireless devices). It will show weather or not your wifi and LAN is either hard blocked or soft blocked. Hard blocked is when the wifi (for example) is blocked by a physical button/switch. Soft block is when it was blocked virtualy though the OS. Before you try and reboot and press the wireless button to activate it, try using the following command: rfkill unblock wifi then check if it is blocked. Use rfkill list to check if its block on unblocked afterwards. This is what my rfkill list look like when everything in unblocked: all unblocked

If it is hard blocked, just reboot and press the wireless botton.

share|improve this answer
    
When I boot it is soft blocked, pressing Fn+F5 has no effect whatsoever (once wifi is working it will disable and enable it). Doing rfkill unblock all brings the wireless (and clearly the networking to life), but the network manager applet shows them both as disabled but the wireless connected to my router. Maybe a network manager bug there. Still, it is soft blocked every time I boot... –  Bracken Mar 24 '12 at 23:07
    
This may sound dumb, but sometimes it may be on airplane mode. Just go into your System Settings, then Network and check on the top right if airplane mode is enabled. It may be that simple (its like that for me sometimes). –  jaorizabal Mar 25 '12 at 1:52
    
I didn't know about that feature, but it was not in airplane mode. –  Bracken Mar 28 '12 at 15:34
    
K try booting up and when you get into the ubuntu loading screen (when booting up, not logging in) press your wireless toggle button and see if it works. Try and press it at diff times during boot up –  jaorizabal Mar 29 '12 at 0:43
    
So, the problem is that the X121e BIOS is unbelievably buggy. Sometimes, use of Fn+F5 permanently latches the WLAN disabled in the BIOS, you have to go in and enable it. –  Bracken Apr 27 '12 at 22:30
up vote 1 down vote accepted

So, the problem is that the X121e BIOS is unbelievably buggy. Sometimes, use of Fn+F5 permanently latches the WLAN disabled in the BIOS, you have to go in and enable it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.