Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to start the Terminal (Applications -> Accessories -> Terminal), it does not start. I get a "Starting Terminal" entry in the taskbar. After a few seconds, it goes away. No terminal appears. (Other applications launch correctly.)

I'm running Ubuntu 11.04, and connecting via Remote Desktop. (On the client, I'm using Microsoft's Remote Desktop Connection for Mac; on the server, sesman.)

I've checked the following log files, but no messages appear: debug, messages, sesman.log, syslog, and user.log.

ps ax | grep -i term does not list the terminal -- not even when the taskbar shows "Starting Terminal". (I can still get a command line by sssh'ing in.)

What should I do? I'm at a loss about how to diagnose and fix the problem.


Thanks for all the good suggestions. When I launch gnome-terminal from xterm, I get the error below. I'm not sure what to do about the error, though.

gnome-terminal: /build/buildd/cairo-1.10.2/src/cairo-image-surface.c:1320: _pixel_to_solid: Assertion `!"reached"' failed.

As for other terminals, I get the same error message when I run Byobu Terminal. And guake didn't install properly from the Software Centre (fixing guake seems beyond the scope of this question). However, xterm runs OK.

Also, I checked my .bashrc file, and it seems fine.

What should I do now? I'd rather not use xterm as my primary terminal.

Update 2

Forgot to check the Google before posting...

This is apparently a known issue. The solution is to turn on a desktop background.

share|improve this question
how did you ps ax | grep -i term without a terminal!? – Andrew Mar 21 '12 at 18:47
also open synaptic and make sure gnome-terminal is installed - you might have uninstalled by accident and then it wasn't removed from the menu – Andrew Mar 21 '12 at 18:48
or install guake, another terminal, very useful! , just run it, press f12 to pop up and f11 to get fullscreen.. – user51537 Mar 21 '12 at 18:51
The error message is likely to be found in ~/.xsession-errors. – lgarzo Mar 21 '12 at 19:19
In case anyone didn't know, ctrl-alt-f4 should take you back to a non X window. ctrl-alt-F7 usually brings you back again. – tomwrong Oct 15 '14 at 18:49
up vote 4 down vote accepted

Try starting the terminal manually, e.g. from xterm and see what the output is.

Press Alt+F2 and then enter "xterm" to get an xterm.

There, simply type "gnome-terminal" to try to start the terminal.

share|improve this answer
+1 I'm curious to see what the output of that would be, too. – Aaron Mar 22 '12 at 12:14

See if there is anything bad in your .bashrc file. That could make the terminal not work. It's a script that runs everytime you launch the terminal, and there is usually a seperate one that gets run when you log in with ssh.

share|improve this answer
or maybe it's only an error on your gnome-terminal ... did you try 'xterm' – maniat1k Mar 21 '12 at 18:41

I had a similar problem after editing the /etc/default/locale

Solution for me was changing the locale in /etc/default/locale back to the defaultc contents of that file to: LANG="en_US.UTF-8" LANGUAGE="en_US"

As described in this answer:

share|improve this answer
It is usually better to give the answer here itself and just link to the answer. I recommend you edit your answer so that whoever sees this answer will immediately know what to do rather than having to go to another site. – Rumesh Mar 8 at 12:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.