Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have switched to unix from last 3 months and trying to understand install process and in particular apt-get.

I am able to successfully install and download the packages when I configure my repository on http location in /etc/apt/sources.list file. e.g.

deb http://web.myspqce.com/u/eng/rose/debian-mirror-squeeze-amd64/mirror/ftp.us.debian.org/debian/ squeeze main contrib non-free

This command will download(/var/cache/apt/archive) and install the package when i use apt-get install

When I change the source location to file instead of http(nfs mount point), the package is getting installed but NOT getting downloaded in /var/cache/apt/archive.

deb file:/deb_repository/debian-mirror-squeeze-amd64/mirror/ftp.us.debian.org/debian/ squeeze main contrib non-free

Please let me know if there is any configuration or settings that i have to make to let apt-get to both download and install package when i use (nfs)file:/ instead of http:/ in sources.list.

To achieve this, I can use apt-get --downlaod-only and then use apt-get install for both download and install in two separate calls, but I want to know why package is not getting downloaded with apt-get install but only getting installed when used with file:/ in sources.list

share|improve this question
    
One update. I cannot even do download only when I use nfs location. e.g. With apt-get --download-only install <package> the command says downloading, but it doesnt actually download the package with the file:/ in the sources.list file. Any help would be greatly appreciated. –  Pravesh Mar 21 '12 at 16:22
    
thanks for the pointers. But as per man page, file:/ options are mainly used when we use nfs mount points. For CDROMs there is separate option as cdrom:/ I will try with deb-copy and update my results here. –  user51538 Mar 21 '12 at 18:52

1 Answer 1

deb-file is mainly used for CDROMs, so downloading them into a cache makes no sense.

Use deb-copy instead.

Source:

$ man sources.list

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.