Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I used Ubuntu with no problems and I upgraded to 11.10 and everything was fine.

But when I did my first suspend I was not able to boot again, all I got was a black screen no bios screen, nothing just blank, I tried doing hard reset but when I power on again same happens. I tried ctrl+alt+delete F1-F12 but i think the keyboard is not working, also tried booting from CD but all I got was blank screen, the hard disk light is not blinking at all so i'm assuming it's not trying to boot.

My laptop is Toshiba satellite with ATI Radeon graphics. Hibernate was working fine though. I searched the net for solutions but with no luck.

Any ideas?

share|improve this question

migrated from stackoverflow.com Mar 21 '12 at 12:50

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Jorge Castro, hbdgaf, John S Gruber, Mitch, fossfreedom Sep 6 '12 at 7:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Not a programming question. Belongs on superuser, unix or ubuntu SE site. –  Konerak Mar 21 '12 at 8:33
This answer should help you solve the problem. –  Aditya Feb 20 '13 at 12:50

2 Answers 2

Unplug the AC adapter, remove the battery, count to 10, and put it all back together, and you should be able to boot again. I recently discovered the same problem with one of my old Toshiba laptops, but I haven't had the time to investigate/test a permanent fix. I'm sure it'll require a kernel boot parameter edit of the grub/grub2 files.

Cheers, Al

share|improve this answer

I had a same issue some time back.

Not all my function keys combination were working on Ubuntu (they worked perfectly fine on Windows), hence I referred to this site for a solution. The site asks us to add GRUB_CMDLINE_LINUX=”acpi_backlight=vendor” to /etc/default/grub file. After I did as the site said, I was facing with the exact black screen problem as you are facing currently. When I removed what I had added, the problem vanished.

May be you want to check if you or some other program had added this extra bit of line in /etc/default/grub file. You can try removing that, rebooting your laptop to see if problem still persists.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.