Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ubuntu 11.10 on hp 6735s, fn keys work for sound adjustment, but for brightness %98 of the times not working, I mean till now only maybe three or four times it worked. always I must set the brightness from boot time (and if I need any adjustment I must reboot and reset)

and this is screenshot for system settings --> screen , it does not contain brightness slider(this change recently happened before there was a slider). (I couldnt upload it here because I'm new user level 1)

enter image description here

share|improve this question
    
@v2r - yes only I have problem with brightness from the begining (BTW it had no problem with ubuntu 11.04). - I use Windows too and in Windows it works fine. - of-course all other combinations work fine. –  Nawras Mar 22 '12 at 7:41
    
@v2r thanks for your help and time, is there any program in ubuntu that can manage brightness? –  Nawras Mar 24 '12 at 8:03
    
the funny thing here is that screen was like your screen shot but now it does not contain brightness slider. it contains:: what to do when battery low and these things. –  Nawras Mar 25 '12 at 19:40
    
@v2r I edited it take a look at the screenshot. –  Nawras Mar 27 '12 at 16:35
    
thank you its working now :)) but still I don't know why!! (how to set this question as answered?) –  Nawras Mar 30 '12 at 13:33

3 Answers 3

I've been having a similar problem and I have looked in a few places but try this...

  1. Open a terminal (Program - Accessories - Terminal)
  2. Type in sudo gedit /etc/default/grub
  3. Find the line that says: GRUB_CMDLINE_LINUX="quiet splash"
  4. Edit it so it says: GRUB_CMDLINE_LINUX="quiet splash acpi_backlight=vendor"
  5. Save and exit
  6. Run the command sudo update-grub
  7. Reboot and enjoy!

And if that doesn't work, instead of restarting try shutting down completely for 10 seconds and then starting up again. And I also tried the same thing and it worked for a while but then when I removed this piece of the line acpi_backlight=vendor and shutdown and turned on my laptop again the brightness buttons worked again.

share|improve this answer

recently, i had the same problem. Here is the link with the solution that worked on my laptop

http://algodecodigo.blogspot.mx/2012/07/problema-al-cambiar-brillo-en-pantalla.html

best regards :)

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Jul 31 '12 at 9:19

Questions, to clarify the Problem:

  1. Did you have this particular problem with "fn+brightness" from the very beginning, since you installed Ubuntu or just recently and do you use a second partition (Windows) in which this problem does not occur?!

  2. Also it would be interesting to know, if the other keys (F1, F2, F3 or arrow key) you use in combination with Fn works fine all the time.


Edit 01: Eventually it is a good idea to see, if you used this key-combination twice, for a different task, which might be conflicting fn+brightness), also a hardware related issue, like a stuck button, or bad contact can now be excluded.

At this point it is a good idea, to file a bug report, after we established that it is only this particular key-combination in Ubuntu, and in your other OS there is no problem at all!

Also take a look at System Settings -> Screen, where you can change/adjust the brightness manually. System Settings comes with the installed OS, see screenshot.

Edit 02: You also could install sudo apt-get install gnome-shell, which allows you, to boot into Ubuntu Unity, as you do right now, but also Unity 2d, Gnome-Shell, Gnome-Shell-Classic etc.., to see if the problem is solved there, or at least if the system settings are working properly. (Referring to your other comment, that "System Settings -> Screen" is missing the brightness-slider).

I am glad, that it worked out for you in the end, even if it is not clear to both of us why! I also deleted all my other comments beneath your question, as we agreed on it and put them in this answer!

share|improve this answer
    
:( :( :( after restart it returned to the same old state –  Nawras Apr 5 '12 at 17:43
    
If this question is still of interest, please take a look here: extensions.gnome.org/extension/231/brightness-control –  v2r Apr 20 '12 at 8:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.