Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have laptop HP Compaq 610 on Intel, and I want to add an additional monitor. I would like this monitor to be a second desktop and not a part of the current desktop, because my laptop resolution is 16:9 and monitor is 16:10

Any ideas how this can be achieved?

share|improve this question

2 Answers 2

You're looking for MultiseatX. It's documented here.

It's a little dated and doesn't include LightDM. It does have directions for KDM and workarounds for GDM.

share|improve this answer
    
You should note that this uses GDM (as was the fashion at the time) and hasn't been updated to LightDM. –  Oli Mar 21 '12 at 12:55
    
But will it work under ubuntu 11.04 ?? –  skowron-line Mar 21 '12 at 14:46
1  
It would appear someone got it working on 11.04 using kdm –  hbdgaf Mar 21 '12 at 15:02

I use the command line utility Disper (there's a PPA, add it with sudo apt-add-repository ppa:disper-dev/ppa && sudo apt-get update, install sudo apt-get install disper) from the alt-F2 dialog box, disper -e will set your desktop to 'Extend mode' and disper -c will clone (mirror) again. disper -s to use only the standard display or disper -S to use the secondary display.

EDIT: changed -m (mirror) to -c (clone)

share|improve this answer
    
after disper -e i get There is no matching crtc for the output , after disper -m was Usage: disper [options] (-l|-s|-c|-e|-p|-i), disper -s switched off secound monitor, adn disper -S switched on secound monitor. So this doesnt work like I want –  skowron-line Mar 22 '12 at 10:50
    
OK, I may have got the letters wrong - do man disper or disper -h to figure it out? –  Andrew Mar 22 '12 at 12:21
    
Dont work for me. Any letter –  skowron-line Mar 23 '12 at 10:09
    
so disper -e doesn't extend, just gives errors? it's supposed to… you should report the bug to the disper development team, on launchpad –  Andrew Mar 25 '12 at 0:26
    
Also, what driver are you using? Default? Proprietary (through Additional Drivers)? Other? –  Andrew Mar 25 '12 at 0:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.