Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to install VLC? (with error showing such).

root@sun-desktop:/var/tmp# apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
vlc is already the newest version.
The following packages were automatically installed and are no longer required:
  liblash3 libreoffice-l10n-common libgsf-1-common libcutter-dev pocketsphinx-hmm-wsj1
  libfluidsynth1 libftgl2 projectm-data libprojectm-qt1 libgnomevfs2-extra libbml0
  libprojectm2 libpocketsphinx1 libsphinxbase1 buzztard-data libbabl-0.0-0
  libgegl-0.0-0 libhal1 libgsf-1-114 libsidplay1 pocketsphinx-utils liboil0.3
  pocketsphinx-lm-wsj libcutter0 cutter-testing-framework-bin
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 239 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up vlc-nox (1.1.9-1ubuntu1.3) ...
/var/lib/dpkg/info/vlc-nox.postinst: 10: /usr/lib/vlc/vlc-cache-gen: not found
dpkg: error processing vlc-nox (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of vlc:
 vlc depends on vlc-nox (= 1.1.9-1ubuntu1.3); however:
  Package vlc-nox is not configured yet.
dpkg: error processing vlc (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                  Errors were encountered while processing:
 vlc-nox
 vlc
E: Sub-process /usr/bin/dpkg returned an error code (1)

# sudo apt-get autoremove vlc vlc-nox
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package vlc is not installed, so not removed
Package vlc-nox is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 237 not upgraded.
share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

This is what I have to do to get it to work

#!/bin/bash
#add VLC (Totem has been removed and Mplayer added)
sudo add-apt-repository ppa:lucid-bleed/ppa
sudo apt-get update
sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc
sudo rm /etc/apt/sources.list.d/lucid-bleed-ppa-lucid.list
sudo apt-get update
sudo apt-get upgrade
echo "now run VLC and set the preferences to allow only one instance."
share|improve this answer
add comment

Type sudo apt-get autoremove vlc vlc-nox. Then after these packages are removed type:

sudo apt-get install vlc
share|improve this answer
    
1.1.13 i am trying to install but it fails: checking for AVCODEC... no configure: error: Could not find libavcodec or libavutil. Use --disable-avcodec to ignore this error. –  YumYumYum Mar 21 '12 at 11:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.