Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I click the right mouse button (anywhere, be it - desktop, browser, console, etc.), the right-click context menu pops up so quickly that the very *first* option in the menu gets clicked. This happens too often to take it easy.

This issue has been brought up a couple of times on Ask Ubuntu, but with no fix whatsoever. This is a very low priority issue for the Ubuntu team, I believe? (How could they?!)

Is there at least a workaround for the issue? Ubuntu is almost unusable for me as it is now.

PS: I have a new mouse. So, please don't go about suggesting that I get a new one - - everything's working fine on Windows 7, so should be the case with ubuntu 11.10, which it is not.

share|improve this question
    
It's possible that you are dragging the mouse down a little as you right click. Right-click to open dialog has nothing selected by default, you have to drag down a little to select first item. Try pushing mouse upwards as you right-click. It's also possible that it's related to your mouse. Have you tried a different mouse to make sure? Right click is not used as much as left click and as such, there's a possibility of that button developing bad contacts from dust, dirt, corrosion, etc. This could allow it to break and remake contact when pushed allowing for more than one click. –  James Apr 22 '12 at 23:44
    
@James I switched to Kubuntu as it allows me to work better (JMO). I plan to try Ubuntu 12.04 LTS when it releases though. Thanks. –  its_me Apr 23 '12 at 0:34

3 Answers 3

Facing the same problem after upgrading from 11.10 to 12.04. Workaround it not to release the right click button immediately -release on the menu item of our choice.

share|improve this answer

Maybe the changing the mouse settings could work for you. In the Dash, search for "Mouse and Touchpad" Once its opened, you can change the settings to see if it solves the problem.

share|improve this answer
    
I did check that - there's nothing related to right-click. (I tried changing though, it didn't work.) –  its_me Mar 21 '12 at 5:55
up vote 0 down vote accepted

Looks like one of the later updates to Ubuntu 12.04 fixed this problem (or it fixed itself magically, which I doubt happened). The problem also no longer persists in 12.10 for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.