Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04 running from an external hard drive (installed on an enclosure) connected via USB port. Like a month or so ago, I increased RAM on my pc from 2 Gigs to 3 Gigs. This resulted on extremely long boot times and slow application loads. While I was understanding the nature of my problem, I posted various threads on this forum ( Questions # 188417, 188801), where I was advised to gather speed tests, and other info on my machine. I was also suggested that I might have problems with the RAM installed. Initially, I did not consider that possibility because:

1) I did a memory test with a diagnostic program from DELL (My pc is from Dell) 2) My pc works fine with Windows XP (the default OS), no problems with memory 3) My pc works fine when booting with Ubuntu 10.10 memory stick, no speed problems 4) My pc works fine when booting with Ubuntu 11.10 memory stick, no speed problems

Anyway, I performed the memory tests suggested. But before doing it, and to check out any possibility of hardware issues on the hard drive, I did the following: (1) purchased a new hard drive enclosure and moved my hard drive to it, (2) purchased a new USB cable and used it to connect my hard drive/enclosure setup to a different USB port on my pc.

Then, I performed speed tests with 1 Gig, 2 Gigs and 3 Gigs of RAM with my Ubuntu 10.04 OS. Ubuntu 10.04 worked well when booted with 1 Gig or 2 Gigs of RAM. When I increased to 3 Gigs, it slowed down to a crawl. I can't understand the relationship between an increase of 1 Gig and the effect it has in Ubuntu 10.04. This doesn't happen with Ubuntu 10.10 and 11.10. Unfortunately for me, Ubuntu 10.04 is my principal work operating system. So, I need a solution for this.

Hardware and system information:

  • DELL Precision 670
  • 2 internal SATA Hard drives
  • Audigy 2 ZS audio system
  • Factory OS: Windows XP Professional SP3
  • NVidia 8400 GTS video card

More info:

williepabon@WP-WrkStation:~$ uname -a
Linux WP-WrkStation 2.6.32-38-generic #83-Ubuntu SMP Wed Jan 4 11:13:04 UTC 2012 i686 GNU/Linux

williepabon@WP-WrkStation:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 10.04.4 LTS
Release:    10.04
Codename:   lucid

Speed test with the 3 Gigs of RAM installed:

williepabon@WP-WrkStation:~$ sudo hdparm -tT /dev/sdc
[sudo] password for williepabon:

/dev/sdc:
Timing cached reads: 84 MB in 2.00 seconds = 41.96 MB/sec
Timing buffered disk reads: 4 MB in 3.81 seconds = 1.05 MB/sec

This is a very slow transfer rate from a hard drive.

I will really appreciate a solution or a work around for this problem. I know that that there are users that have Ubuntu 10.04 with 3 Gigs or more of RAM and they don't have this problem.

share|improve this question
1  
I think your suspicion this is connected to ehci is right, and you should try googling that to look for ways to fix it. –  poolie Mar 21 '12 at 22:31
add comment

2 Answers

try a newer kernel. Install linux-image-generic-lts-backport-oneiric. I use this line of kernels, and I have no problem.

Open synaptic and select the package. That is the easiest mode. The package installation system will do the rest.

share|improve this answer
    
That's a good idea: possibly a solution; certainly will get more data. –  poolie Mar 22 '12 at 9:29
    
Need to be educated on how t do this kernel install. Have never done it. On the other hand, I would like to keep 10.04 LTS (Lucid). –  williepabon Mar 22 '12 at 11:35
1  
Just type into the terminal sudo apt-get install linux-image-generic-lts-backport-oneiric and press enter. You can also select it from synaptic. You will remain on Lucid, but the kernel will be more up to date. –  gajdipajti Mar 22 '12 at 15:43
    
Will like to try this, but couldn't find oneiric image on Synaptic. Al my software sources point to ... Lucid Linx. Please, advice. –  williepabon Mar 22 '12 at 22:13
1  
You need to enable in synaptic the lucid-updates and lucid-proposed. If you click the settings menu, choose the second option from the top, and in the new window select the updates tab. When you are done, refresh, update your system, and select the new kernel package. –  gajdipajti Mar 22 '12 at 22:50
show 4 more comments

I do know there are some motherboards/chip sets that perform very poorly when you have un-paired or mismatched memory, and that was my first thought when I heard increasing memory slowed things down.

However the fact that it varies across OS's seems to indicate it's not so simple.

One thing you could try is adding a mem=2G boot parameter when booting with 3G physical memory installed.

share|improve this answer
    
I tried this work around, but I didn't help. I'm including here info about my machine and OS and also copy of the GRUB file, to see if it can help to diagnose the problem.[sudo] password for williepabon: Linux WP-WrkStation 2.6.32-39-generic-pae #86-Ubuntu SMP Mon Feb 13 23:05:11 UTC 2012 i686 GNU/Linux –  williepabon Mar 21 '12 at 13:15
    
@williepabon - remember this is a question and answer site - so important information such as this comment should be edited into your question - stuff like this should not be buried in comments. thanks. –  fossfreedom Mar 21 '12 at 22:28
    
Still learning on how to use this system. Sorry –  williepabon Mar 22 '12 at 11:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.