Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an external HDD (640 GB), with file system FAT32. I want to change the ownership of it from root (default) to angstrem (my username). The system is mounted to /media/exthdd. I try to do that by a command:

sudo chown -vR angstrem:angstrem /media/exthdd

and after that the system gives me an error:

chown: changing ownership of `/media/exthdd': Operation not permitted

If anybody knows, please tell me, how to change ownership of that HDD?

share|improve this question
    
see this askubuntu.com/questions/88080/… –  Ringtail Mar 20 '12 at 21:22
    
I tested this and found that when I mount external HDs I am automatically made the owner of the relevant /media/<name> –  cprofitt Mar 21 '12 at 1:34
add comment

1 Answer 1

up vote 1 down vote accepted

FAT doesn't support file ownership, so you need to specify the owner when you mount the device. You can do this by adding uid and gid options to your mount command.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.