Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted a question before at Dell monitor not detected (Ubuntu 11.10) but I figured it's best to create a separate question since the real issue at hand is not really tied to my monitor and the info was previously all over the place.

Basically, I can't access nvidia-settings. If I try I get the following error : You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

Here is what my xorg.conf looked like :

$ cat /etc/X11/xorg.conf.initial 
Section "Device"
    Identifier  "Default Device"
    Option  "NoLogo"    "True"
EndSection

So I tried to run nvidia-xconfig, but it failed with following error :

$ sudo nvidia-xconfig 
[sudo] password for cmenguy: 

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
                  Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

And here is what the new xorg.conf looks like :

$ cat /etc/X11/xorg.conf.backup 
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 280.13  (buildmeister@swio-display-x86-rhel47-05.nvidia.com)  Wed Jul 27 17:18:55 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

And I still get the same error with nvidia-settings...

My Graphic card is a nVidia GF106 (I got that from my lspci output) :

$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation GF106 [Quadro 2000M] (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)
0d:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 08)
0d:00.3 FireWire (IEEE 1394): Ricoh Co Ltd FireWire Host Controller (rev 04)
0e:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

I've also installed the latest available driver with additional driver and rebooted once.

Can someone tell me what I'm doing wrong? And can I reboot the PC with this new xorg.conf with no risk to be stuck with no graphical interface?

Thanks !

share|improve this question
    
It looks ok to me - besides, it saved your old one to '/etc/X11/xorg.conf.backup'. In regards to running 'nvidia-settings', to do that, hit <alt>+F2 and type gksudo nvidia-settings, enter your password, and you'll have Super User privileges in the GUI config util. –  Jayson Rowe Mar 20 '12 at 20:47
    
Would you advise that I try and reboot to see what happens? I guess until I reboot, nvidia-settings won't look at the right xorg.conf, right? –  Charles Menguy Mar 20 '12 at 20:57
    
I changed the xorg.conf and rebooted, but this totally killed my graphic interface, so I replaced to the old "dummy" file shown above. One thing I noticed is that when I boot from the live CD, my extra monitor is recognized ! and not in my real Ubuntu install, which is why I'm going through all this pain with the drivers/xorg... Any thoughts? –  Charles Menguy Mar 20 '12 at 21:51
    
did you try 'gksudo nvidia-settings' to see if it recognized your monitor? once you hit apply to "try" the new settings, you can then choose to write out a new xorg.conf –  Jayson Rowe Mar 20 '12 at 21:58
    
I had another thought as well - if it's working via the LiveCD it is working without the proprietary Nvidia Drivers loaded (which you have loaded if you are using nvidia-xconfig or nvidia-settings. Perhaps you can try uninstalling those drivers just to see if your second monitor works, and then go from there (re-installing the drivers, running nvidia-settings with gksu). –  Jayson Rowe Mar 21 '12 at 0:29

2 Answers 2

That sounds just like you have installed the wrong driver package. nvidia-current is the package you need for your card and driver version 280.13 from the Ubuntu repository should suffice. Please remove all the other proprietary graphics drivers repositories you have installed while troubleshooting. Using ppa-purge is recommened.

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ppaowner/ppaname

ppa:ppaowner/ppaname = is the same URL you used for adding the repository with add-apt-repository

Also remove all the other proprietary graphics drivers you might have installed via Jockey GUI or terminal. Backup your current xorg.conf file and delete the original.

Now install the driver:

sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

A new xorg.conf should be created during installation. After a reboot you should be able to run nvidia-settings without further disturbances.

There is the X Updates repository with the latest drivers you can try after you got the driver from the Ubuntu repositories running

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get remove nvidia-current nvidia-settings
sudo apt-get install nvidia-current-updates nvidia-settings-updates
share|improve this answer
    
So I removed the driver through the web interface in system settings > additional drivers by clicking "remove", and then installed both nvidia current and settings as instructed (not sure about the ppa stuff, i didn't add any repository before). I don't see any new xorg.conf, how can I regenerate a new one? If i try to do "sudo X - configure", i get the following message "Fatal server error: Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. " any thoughts? –  Charles Menguy Mar 21 '12 at 14:24

Okay so I finally got it working, so I'm posting my solution for others.

The problem was indeed the nVidia Optimus card. So I went into the BIOS, set this to Discrete mode, and disable OS detection feature.

After rebooting, I installed the nVidia driver in additional drivers, rebooted again, and I was (finally) able to access this nvidia-settings panel and get my second monitor workign !

Cheers

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.