Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Logitech QuickCam Communicate STX webcan that was plug and play when I bought it a few years back. I have used it a few times on Skype when it seemed okay, but have been trying to use it with Google+ Hangouts. There I found that it would be okay at first, but then the picture would freeze. Sound through the built-in microphone is fine.

I wondered if it was the Google plug-in, but just doing some experiments with Cheese and that freezes too. I can seem to un-freeze that (for a second or 2) by waving a hand in front of the camera. Could something be shutting down if it doesn't detect enough movement?

I'm running Kubuntu 11.10. Any suggestions on things to look at?

share|improve this question

closed as too localized by Eric Carvalho, Seth, bodhi.zazen, belacq, Amith KK Feb 8 '13 at 4:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. –  Aditya Feb 7 '13 at 18:52
    
I wouldn't say it's too localized: bugs.launchpad.net/ubuntu/+source/libv4l/+bug/984603 –  int_ua Jan 11 at 21:04

1 Answer 1

Many applications, like webcams, doesn't seem to work well (or at all) with V4L2. But luckily there is a simple workaround to avoid the problem, through installing and loading some libraries with backward-compatibility with V4L, so that Flash sees again your Webcam, as it used to do until Ubuntu Hardy.

sudo apt-get install ld.so.preload-manager

after that execute:

sudo ld.so.preload-manager /usr/lib/libv4l/v4l1compat.so

Then, you have to switch the video mode to V4L from the multimedia systems selector, through executing the following in a terminal:

gstreamer-properties

Go to the Video tab, and change the default value to V4L.

share|improve this answer
    
ld.so.preload-manager doesn't seem to be available as a package on 11.10. I see your answer came from UBuntu wiki. Maybe that needs updating help.ubuntu.com/community/Webcam/… –  steevc Mar 20 '12 at 15:09
    
thanks for finding the source... I had cut-n-pasted that to a set of notes I have for my kids computers and did not have the source. They are on 11.04 so it looks like I too will be looking for a new set of instructions. –  cprofitt Mar 20 '12 at 15:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.