Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 64bit and trying to install wine 1.5, using this method:

Install Wine on Ubuntu:

sudo apt-get install libfreetype6-dev gobject* libxrender-dev libfontconfig-dev pthread* libpthread-stubs0-dev xext* libsm-dev

and copy the following commands in the Terminal:

wget http://prdownloads.sourceforge.net/wine/wine-1.5.0.tar.bz2
tar -xjvf wine-1.5.0.tar.bz2
cd wine-1.5.0

Install some packages:

sudo apt-get install flex bison qt3-dev-tools qt4-qmake
cd tools

All goes well, but at the end, I get this error message:

checking for -lfreetype... not found
configure: error: FreeType 32-bit development files not found. Fonts will not be built. 
Use the --without-freetype option if you really want this.

Does anyone know how to install lfreetype?

share|improve this question

9 Answers 9

up vote 2 down vote accepted

Revert http://source.winehq.org/git/wine.git/commitdiff/a37f74f5adec8cd3f924fc96e083a66219086091 from your source tree and compile again.

share|improve this answer

It complains about missing the 32bit dev package of freetype.
You can try installing it with sudo apt-get install libfreetype6-dev:i386 and see if the warning has gone.

share|improve this answer
Thanks, but I have 64bit and I have installed: sudo apt-get install libfreetype6-dev .... I am wondering if wine 1.5 is only available in i386... However did add 64bit version, still same issue.. sudo apt-get install libfreetype6-dev –  pst007x Mar 25 '12 at 11:00
Please read which packages will be removed from your system before attempting the above command Users have reported the removal of system-critical packages. –  earthmeLon May 21 '12 at 4:41

Get to the directory that you've extracted the files for wine.

In terminal, run this command:

./configure --without-freetype

Then after it's completely done, run:

share|improve this answer
PKG_CONFIG_LIBDIR=/usr/lib/pkgconfig ./configure

Try configure with that line. It might be your trying to compile on 64 bit system a 32 bit wine and you will find that configure sometimes checks in wrong place for the libs.

share|improve this answer

Try this:

sudo apt-file search FreeType 32-bit development files(missing file name)

The output return the package which the FreeType 32-bit development files belong to

sudo apt-get install 'package'

detail usage

share|improve this answer
pst007x@pst007x-Serval-Professional:/$ sudo apt-file search lfreetype .... Nothing happens? I have manually searched but cannot find that package... Thanks –  pst007x Mar 20 '12 at 23:55
@pst007x:Is lfreetype the missing file's name ? Do you execute 'sudo apt-file update ' command before using 'sudo apt-file search'? –  LFJ Mar 21 '12 at 1:28

well instead you sudo what you what it's better you just go to Ubuntu software center and get what you want, comes all in one so you don't have to sudo them all just click one thing and everything come in a package, ready to be use...

share|improve this answer
ln -s /usr/include/freetype2/freetype /usr/include
share|improve this answer
After flags (like -s), the ln command takes its first argument as the target of the link, and the second argument (if present) as the source. The command you've posted will try to create /usr/include as a symbolic link to /usr/include/freetype2/freetype, which will invariably fail since any Ubuntu system already has a real /usr/include directory. Did you mean it the other way around? –  Eliah Kagan Jun 21 '12 at 10:24


The problem is that Ubuntu pkg-config doesn't see your FreeType 32-bit development files.

  • To verify that this is the case, you can check it by the following command:

    pkg-config --cflags --libs freetype2

    You should have the error, that pkg-config can't find this package.

    Note: If you don't have pkg-config, please install it via sudo apt-get install pkg-config

  • Then, please verify if your freetype was installed correctly and where.

    $ dpkg -l | grep freetype        
    $ sudo updatedb && locate freetype2
  • Try to reinstall it, just in case:

    sudo apt-get update && sudo apt-get install libfreetype6-dev --reinstall
  • If still doesn't work, please find your pc file in your freetype package:

    dpkg -L libfreetype6 libfreetype6-dev | grep pc$

    or anywhere else:

    sudo updatedb && locate freetype2.pc

    and make sure that this file is linked up inside your pkgconfig directory (locate pkgconfig):

    ln -s YOUR_FOUND_PATH/freetype2.pc /usr/lib/x86_64-linux-gnu/pkgconfig/freetype2.pc

    Note: Replace YOUR_FOUND_PATH with your full path of freetype2.pc file.

  • If you can't find your pc file, please create one inside your pkc_config dir (as freetype2.pc):

    Name: FreeType 2
    Description: A free, high-quality, and portable font engine.
    Version: 14.0.8
    Libs: -L${libdir} -lfreetype
    Libs.private: -lz  
    Cflags: -I${includedir}/freetype2 -I${includedir}
  • If your problem is still not solved (or it's related to something else), please debug your ./configure script in shell:

    $ sh -x ./configure

    And find the place of your problem (e.g. which pkg-config command is executed to verify existence of the specific package).


If you have similar problem on Mac and you found this topic, please use homebrew to install your freetype package:

sudo brew install freetype

If you still have the problem, check this bug: https://github.com/mxcl/homebrew/issues/14550

share|improve this answer

I installed freetype from source http://sourceforge.net/projects/freetype/files/ with

./configure --without-png 
sudo make install
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.