Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded two versions of Ubuntu to Oneiric after a recent set of updates broke Audacious 2.4.something in Maverick for me. When it was all finished my Asus Eee 1215N with the 1366x768 screen and the notoriously unsupported Nvidia Ion2 with Optimus chipset was working on minimum compatibility fallbacks at 1024x768 resolution (probably on only the Intel part). So I did a little bit of reading (not enough) and tried deleting a couple parts of the graphics system to see if I could force a retry on the autodetection. The result: No graphical shell works now. Attempted so far: -reinstalling xorg/nouveau drivers, didn't work but perhaps I read the wrong instructions. -installing bumblebee/nvidia-current (followed the directions), didn't work. -sudo dpkg-reconfigure -phigh -a, it didn't take as long as it probably should have but didn't work.

Right now I'm looking at what it takes to disable the splash screens, which do still work, so that I can hopefully diagnose my error messages; if someone knows where this stuff goes as a boot-log that would be awesome to know. This is otherwise a functional installation that I had spent some time setting up already (including a successful compile of Audacious 3.21 that was working with all the plugins). Is there a way for me to rebuild the graphics system from scratch or should I just give up, cry a little, backup data, wipe partition and reinstall with a USB drive?

User Lekensteyn is probably hitting the nail on the head about me stepping on the MrMEEE/Bumblebee landmine; several months ago (a year? after he'd fixed the rm -r -f /usr bug) I tried installing that mess but it never seemed to do what it was supposed to so I removed it. It's entirely possible that I didn't manage to shovel all of that pile off my system.

http://paste.ubuntu.com/892799/ --Xorg.0.log

Managed to suppress splash pages a little bit, using steps 1-4 of instructions found here: http://www.techienote.com/2012/01/disable-gui-boot-in-ubuntu-11-10.html Saw a couple errors that make it possible to start diagnosing,

[   14.645074] [drm:intel_dsm_platform-mx_info] *ERROR* MUX INFO call failed
[   14.645266] [drm:intel_dsm_platform-mx_info] *ERROR* MUX INFO call failed

Also, when I try to use startx it complains: No protocol specified

share|improve this question
    
Can you paste.ubuntu.com your /var/log/Xorg.0.log file and post the link in your question? –  Lekensteyn Mar 20 '12 at 16:34
add comment

2 Answers

I'm no expert as I never had Nvidia GPUs, but have you tried this?

sudo apt-get install ppa-purge
sudo ppa-purge ppa:mj-casalogic/bumblebee
sudo ppa-purge ppa:mj-casalogic/ironhide
sudo apt-get purge bumblebee ironhide nvidia-current
sudo add-apt-repository ppa:ubuntu-x-swat/x-update
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee-nvidia
sudo usermod -a -G bumblebee $USER
sudo reboot now

These are some instructions I found in the ppa for the Bumblebee Project. Good luck! ;)

share|improve this answer
    
Note: upgrading from MrMEEE/bumblebee is not fully supported due to the mess created by it. See also wiki.bumblebee-project.org/Upgrading-on-Ubuntu –  Lekensteyn Mar 20 '12 at 14:55
add comment

After a fresh install and before doing ANYTHING else (i.e. do not install nvidia proprietary driver)

The following four commands

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia

sudo usermod -a -G bumblebee $USER

Reboot or re-login

Worked for me after months of struggling. (Asus N53SN)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.