Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My desk is situated at the edge of the range of a wireless signal which I use occasionally (when away from my desk) and is therefore saved in network manager. At my desk, however, I plug into the ethernet cable. While I'm working the computer is constantly trying to join the wireless network and usually failing this results in two annoying behaviors.

1: In gnome shell the network connect and disconnect notices keep popping up at the bottom of the screen and I have to click them to make them disappear (I assume it's been fixed in the next version of gnome).

2: (the worst!) Occasionally the wifi password dialog will pop up and ask for the password to this network (which is already saved). An additionally annoyance is that in gnome shell I'll get two copies of the dialog that I have to cancel, one is gnome shell themed (no window border etc...) and the other is just normal gnome themed. (Sometimes if I've been away from the computer for a while I will have multiple copies of this dialog up as its been trying to connect for a while resulting in at times 20 dialogs to cancel).

Note, all the while I've been happily connected to the ethernet and have full network access.

This is incredibly annoying and distracting, why doesn't ubuntu stop trying to connect to wifi if I'm on the ethernet (unless I want to broadcast my own network, but that's different)?

share|improve this question
1  
I've reported this as a bug: bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/… –  user53511 Apr 4 '12 at 23:33
    
Thanks, I've ended up just using the hardware switch when I'm on the ethernet, thankfully the driver has no problems loading and unloading based on the switch. –  labarna Apr 30 '12 at 2:10
add comment

1 Answer

Well, it obviously should check for ethernet connection first, so it's a bug, and you should file a bug report against the network-manager package.

ubuntu-bug network-manager

For more info, see the bug filing howto: https://help.ubuntu.com/community/ReportingBugs

Meanwhile, disable auto-connecting to that network:

  • right click the network applet in the panel
  • select "Edit Connections..."
  • select the Wireless tab and double click the network
  • uncheck the "Connect Automatically" box
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.