Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Lately my mouse is misbehaving and from time to time a double click event is received when what I mean is a single click.

Given that there's a configuration to set the timeout by which two separate single clicks are joined together as a double click, I was wondering if it's possible to do the opposite, that is, discard a double click when the two single clicks happened before a timeout.

share|improve this question

closed as too localized by RolandiXor, Eliah Kagan, Luis Alvarado, Tom Brossman, fabricator4 Jan 2 '13 at 9:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Just to clarify things, when a single click is mistakenly interpreted as double click event, you really mean one single click and not two single clicks? –  lumbric Mar 19 '12 at 17:19
    
@lumbric Yes, that's correct, I would like to get just one single click. –  jcollado Mar 19 '12 at 23:07
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  RolandiXor Jan 2 '13 at 4:03
    
Not sure this is abandoned as this is an established user with recent logins. It's probably too localised though, if it's a hardware problem. @jcollado I've voted to close this but if you want to edit the question with any new info please do. –  Tom Brossman Jan 2 '13 at 8:06
    
I'm having this problem lately. And I've checked the double click timeout, and found that even in the test area, the timing seems to be inconsistent. –  Catskul May 31 '13 at 0:00

1 Answer 1

up vote 1 down vote accepted

You can adjust the 'Double Click Timeout' in All Settings -> Mouse and Touchpad -> 'Double-Click Timeout' and adjust the slider to your personal preference.

Mouse prefs

That said, if you are getting inconsistent results then the source of the problem is most likely intermittent hardware failure or user error. I'll assume you can click or double-click just fine, so try a different mouse if this settings change doesn't help.

share|improve this answer
1  
The mouse seems to be back and I'm no longer getting the same problem. However, your answer seems reasonable, so I'm going to accept it. If I get the same problem again, I'll update the question if this doesn't work. Thanks! –  jcollado Jan 2 '13 at 8:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.