Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed Ubuntu 11.04 on my Netbook. I had to use a flash key and during the installation i tried putting Ubuntu on a separate partition, but it kept showing a no root file system is defined error.

I didn't really know what i could do to fix it, so i decided to install it alongside Windows. I have a windows7 installation, which works perfectly fine. So the installation goes through perfectly and i give both OS's 40 Gigs of space. The comp restarts and NOTHING!

The computer boots directly into Windows. During the install it said i am supposed to be prompted at boot, and nothing happened. Ubuntu partitioned the C: drive, but this partition doesn't show up in Windows. If i boot using the flash drive, it shows the partition with the Ubuntu installation. I tried reinstalling, but now i don't get the prompt to asking me to install Ubuntu.

Really confused ..

share|improve this question
It's possible Grub was installed to the flash drive. I had this happen once several years ago and the computer would not boot unless the flash drive was attached, even though I had another system installed on the hard drive. – Pete Rose Aug 31 at 3:10

1 Answer 1

up vote 1 down vote accepted

It sounds like you have two disk drives and the boot loader was installed to the wrong drive. Either tell your BIOS to boot from the other drive, or reinstall, and make sure you direct grub to the correct drive.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.