Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I saw my old Notebook yesterday and wanted to make that work again. On Windows XP the wireless worked still fine. Then I installed new Ubuntu 11.10 32bit and I'm sadly not able to make the wireless enabled. [I replaced Win XP entirely]

lspci lists following network:

08:0a.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

So after recommendation from this link I installed the b43 firmware module.

iwconfig prints the following:

wlan0   IEEE 802.11bg ESSID:off/any
        Mode:Managed Access Point: Not-Associatd  Tx-Power=off
        Retry long limit:7  RTS thr:off   Fragment thr:off
        Power Management: off

As you can see, my wireless lan adapter is not turned on.

sudo iwconfig wlan0 txpower auto

Doesn't change anything. Then I tried to make it work with rfkill.

rfkill list
    0: phy0: Wirless LAN
            Soft blocked: no
            Hard blocked: yes
sudo rfkill unblock all
rfkill list
    0: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: yes

remains the same.

The question is now, how I could enable the hard blocked wireless LAN. There is no hardware switch for wlan integrated. However there is a button to change the state. I always thought this would be software sided, but it seems to make some hardware changes as well... The wireless LED is also not blinking (as it did on windows xp)

I reset bios and searched for some settings in there, but it has only a few options and nothing to do with wireless settings, nothing works here..

At last I tried to install the acer hotkeys but I was not able to manage that. I installed the acerhkgui package, but in initializing progress, it was not able to compile acer hotkeys for my machine. There was a message that asm/linkage.h was not found while compiling.

Do you have any ideas what I could do to make this hard blocked stuff disabled and my wireless card work?

PS: I also tried sudo rm /dev/rfkill and a reboot to reinit that stuff... No success :(

share|improve this question

closed as too localized by Eliah Kagan, Seth, Nathan Osman, RolandiXor, Amith KK Feb 15 '13 at 7:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. –  Eliah Kagan Feb 15 '13 at 3:14

Browse other questions tagged or ask your own question.