Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung R530 laptop. I'm actually running Linux Mint, which is based on Ubuntu (which is why I thought it would be OK to post this here). I'm now getting exactly the same problem on Ubuntu 10.10.

I've got it setup with a secondary LCD monitor, and I've changed the display settings so the laptop screen and monitor are at optimal resolution, with the desktop shared between them. After startup though (typically around 10-30 seconds) the display reverts to 1024 x 768 on both screens, and the display is duplicated (i.e. both screens show the same thing).

I think this is something to do with my video card, as I had the same problem when I was running Arch Linux. Any ideas?

Edit:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller

It seems it's Intel, not Nvidia.

I have a current work around, which is to have a launcher to a script containing

xrandr --output LVDS1 --mode 1366x768 --output HDMI1 --mode 1280x1024 --left-of LVDS1

on my desktop, and to run it after the displays revert, but it's not ideal.

share|improve this question

closed as too localized by Marco Ceppi Sep 24 '11 at 13:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What did you use to change the display resolution? What graphicscard does your Laptop have? –  Bobby Nov 4 '10 at 21:23
    
I used the control centre Monitors tool. I think it's an nvidia one, but I don't know. –  Skilldrick Nov 4 '10 at 21:25
    
Can you post the output of lspci? –  Nick Pascucci Nov 4 '10 at 22:42
    
@codeMonk - Sorry for the delay, there you go. –  Skilldrick Nov 7 '10 at 17:51

1 Answer 1

You need to save the settings to your xorg.conf file. This should maintain your settings when you reboot etc.

share|improve this answer
    
This should be in the menu, no need to use a command to start it. –  trampster Nov 4 '10 at 23:11
    
It is in the menu, sorry. I'm just accustomed to using grun etc, so I tend to include such methods. Thanks for the tip though. –  RolandiXor Nov 5 '10 at 1:58
    
Sorry, my mistake, it's an Intel card, not Nvidia. –  Skilldrick Nov 7 '10 at 17:53
    
loool... well the solution is still basically the same, I'll update my answer. –  RolandiXor Nov 7 '10 at 18:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.