Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run XFCE4 on Ubuntu 11.10.

When I plug in a USB memory stick, I get two new windows popping up, both showing the contents of the memory stick. One is Thunar (which I want) and one is nautilus (which I don't).

Before I plug in the stick, nautilus isn't running at all. Something is spawning it, but I don't know what, or how to stop it.

This is what the Nautilus->Edit->Preferences dialog looks like. There's no Media tab:

enter image description here

share|improve this question
add comment

2 Answers

On Ubuntu 12.04, You can follow this procedure:

  • First install dconf-tools by the command sudo apt-get install dconf-tools.
  • Then open the dconf-editor by pressing Alt-F2 and typing dconf-editor.
  • In the dconf-editor window, go to the following steps:

    org -> gnome -> desktop -> media-handling 
    

    then uncheck automount_open options

  • Exit dconf-editor.

Source: This page on Ubuntu forums

share|improve this answer
    
Welcome to Ask Ubuntu, though the link can answer the question, It is preferable to include the details here –  Anwar Shah Jun 28 '12 at 12:03
    
in dconf-editor for me, there is no media-handling option, and I can't find automount_open anywhere. –  Benubird Dec 11 '12 at 9:15
    
if you dont want to install new software , you can use the command gsettings set org.gnome.desktop.media-handling automount false –  vanjoe Feb 25 at 20:19
add comment

If you are not using nautilus in xfce, you can remove nautilus from synaptic.

Else, open

Nautilus ->Edit ->Preferences-> Media

and set every option to "Do Nothing" and

Check the option "Never prompt or start programs on media insertion"

Uncheck "Browse media when Inserted"

share|improve this answer
1  
I don't think removing nautilus is a good idea, because I think that will stop it working for the other people who use the computer. I tried uncheckinging that option, but couldn't find it. I added a screenshot of the Preferences window to my question - there's no Media tab. –  Chris Moore Mar 19 '12 at 3:57
    
As you can see from the screenshot in the question, there is no media tab in preferences. –  Benubird Dec 11 '12 at 9:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.