Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble to connect my Ubuntu 11.10 to internet through ethernet. I installed a router to get Wi-Fi and now (by a wired connection) I can't have internet with ubuntu (but I can with Windows 7). I see several attempts per minute of the network-manager to get a connection, but after a minute it stops trying. Here are a couple of outputs from key files:

cat /etc/network/interfaces

auto lo
iface lo inet loopback


ifconfig -a

eth0      Link encap:Ethernet  HWaddr 00:16:76:e4:a6:e8  
          inet6 addr: fe80::216:76ff:fee4:a6e8/64 Scope:Link
          RX packets:0 errors:117 dropped:0 overruns:0 frame:117
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:12221 (12.2 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:582 errors:0 dropped:0 overruns:0 frame:0
          TX packets:582 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:46024 (46.0 KB)  TX bytes:46024 (46.0 KB)

I tried reconnecting the modem and the router and reconnecting the ethernet cable but nothing... I tried other solutions from other posts (this one has a similar issue Wired connection not working) but again nothing. My IP is dynamic.

A couple of things I see and did:

  • I see no inet addr, only inet6. I ignored ipv6 from the internet connections, and restarted the network-manager service and nothing.
  • A difference with the post I mentioned is the RX packets with errors I have, is this a clue of the problem?

Any help would be appreciated, Thanks!

share|improve this question

Try to run dhclient eth0 (It will get you an IP address from the router: if it is configured to do so).

If that method works go to network connections; select your wired connection and click edit; go to IPv4 settings tab; change the method to Automatic (DHCP).

Or you can simply add the following lines to /etc/network/interfaces

auto eth0
iface eth0 inet dhcp
share|improve this answer
sorry...dthat didn't work. The "dhclient eth0" just hangs...and the modifications in the interfaces file make ubuntu don't recognize my connection. Any other suggestion? – talabes Mar 19 '12 at 23:55
Just wanted to say it worked for me (exact same issue, exact same OSes). – Alexandre P. Levasseur Jul 25 '12 at 22:57

I had the same problems with wired connection: Now I have overcome it as follow. Use the terminal:

1. sudo dhclient eth0 <-- will work but I have to do it every time I turn on the computer.(Should it fail, on/off the wireless using wcid. It works most of the time.)
2. try plug and unplug the cable <-- I tried very often but sooner or later the whole   socket will be damage.
3 Best choice so far: IT WORKS.
terminal: gedit dhclient eth0 

Your doc must be modified. See below

auto lo
iface lo inet loopback

# auto eth0
# iface eth0 inet static
#  address
#  netmask

save and exit. This should work now. Good Luck.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.