Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am very very new bie in the world of Ubuntu. I have recently installed Ubuntu 11.10 and I am not able to connect to Windows VPN.

When I login to Windows 8 I am able to connect to VPN using default Windows VPN connection.

Any help pointers?

share|improve this question
    
We would need to know what type of VPN you are connecting to. (PPTP, L2TP, IPsec, etc). –  Jayson Rowe Mar 19 '12 at 2:26
    
I am able to connect to VPN using windows default VPN connector. I guess it uses PPTP. –  Sudhir Kesharwani Mar 24 '12 at 14:19
add comment

3 Answers

up vote 4 down vote accepted

How to set up VPN in Ubuntu (when you know the parameters to configure):

Click the network icon in the panel → VPN ConnectionsConfigure VPN.

addvpn1

Go to VPN tab → Add.

addvpn2

Create.

addvpn3

Enter settings, optionally mark Connect automatically, Save.

addvpn4

You can connect via the network icon in the panel.

connectvpn

Ps. If you're trying to connect to a Windows VPN and still not working, try the below method suggested by Jason Rowe:

Try going into "Advanced" on the VPN tab and enable "Use Point-to-Point encryption (MPPE)", set security to "All Available (Default)" and tick the boxes for "Allow BSD data compression", "Allow Deflate data compression", and "Use TCP header compression".

share|improve this answer
1  
Hi, thanks for your answer, I have done above settings, but still I get that it is not able to connect to VPN. –  Sudhir Kesharwani Mar 24 '12 at 14:20
    
I can't seem to figure out what package that icon on the panel is inside of. I can create a VPN connection but not see that. –  Warren P May 18 '12 at 19:35
add comment

Thanks for the additional info.

Try going into "Advanced" on the VPN tab and enable "Use Point-to-Point encryption (MPPE)", set security to "All Available (Default)" and tick the boxes for "Allow BSD data compression", "Allow Deflate data compression", and "Use TCP header compression".

share|improve this answer
    
Thanks a lot Jayson, that worked like charm for me :) you are the master :) –  Sudhir Kesharwani Mar 26 '12 at 2:35
    
Happy to help, Sudhir. I'm glad it worked for you. –  Jayson Rowe Mar 26 '12 at 2:37
add comment

click "advanced" button, then only select MSCHAP and MSCHAPv2 authentication methods. You'd better select every option in other fields.

share|improve this answer
1  
This does not provide a sufficient answer to the question. Try to add more information, and / or examples. –  Mitch Oct 7 '12 at 10:26
    
This was the case for me - though I had to disable MSCHAP and only have MSCHAPv2 checked in order to connect. GG, Microsoft. –  sudowned Jul 23 '13 at 22:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.