Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a machine with a Nvidia 8600GT graphics card and a CRT monitor. Previously, I have only used Windows on it, and the graphics card seems to be working correctly in Windows 7. I booted up and installed Ubuntu 11.10 amd64 from the LiveCD and the whole process worked perfectly. When I tried to boot off the hard disk for the first time, the output to the monitor switched off during the splash screen, and this happens consistently. I can ctrl-alt-f2, so I tried an apt-get upgrade, which didn't help; nor did apt-get install nvidia-current. There is nothing that looks relevant in dmesg. Booting with the nomodeset option has no effect.

Following the answers in this similar thread, I tried apt-get purge nvidia-173. Both startx and service lightdm start just say the service is already running.

Does anyone know how to find out what the problem is? I was wondering if it is just that Ubuntu is trying to use a resolution that the monitor doesn't support, but I can't find out how to change that from the command line.

share|improve this question

Xorg might need to be reconfigured...

I had a similar situation. This is what I did which gave me a graphical login screen after a restart:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo cp /etc/X11/xorg.conf.failsafe /etc/X11/xorg.conf

Here's the contents of my /etc/X11/xorg.conf.failsafe:

Section "Device"
   Identifier  "Configured Video Device"
   Driver      "fbdev"

Section "Monitor"
   Identifier  "Configured Monitor"

Section "Screen"
   Identifier  "Default Screen"
   Monitor     "Configured Monitor"
   Device      "Configured Video Device"

Something else you might look into:

Xorg -reconfigure

Something else you might look into is just removing the /etc/X11/xorg.conf file entirely and (restarting and) seeing what happens.

share|improve this answer
Thanks for the help. Unfortunately, I don't have a /etc/X11/xorg.conf.failsafe, and Xorg doesn't seem to have a reconfigure option. I tried Xorg -configure from the recovery mode root shell (which is apparently needed to generate some of the Xorg.conf files in 11.10), and it fails with the message Fatal server error: Could not create lock file in /tmp/.tX0-lock. I also discovered xrandr and tried playing with some of the output options to no avail. – James Mar 19 '12 at 10:50
Your could not create lock file error sounds like you might have a much larger issue--meaning, it might be easiest to just reinstall. Other than that, I posted the contents of my failsafe config file just in case. – tdowg1 Mar 19 '12 at 22:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.