Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ThinkPad W500 used to crash sometimes under heavy load because the automatic control is not speeding up the fan far enough. But I was able to disengage the fan and let it run at full speed in Ubuntu 10.10. But this does not work in my new nice and shiny Ubuntu 11.10.

Have a glimpse at fan control device.

% ls -l /proc/acpi/ibm/fan
-rw-r--r-- 1 root root 0 2012-03-18 15:46 /proc/acpi/ibm/fan
% cat /proc/acpi/ibm/fan 
status:     enabled
speed:      3056
level:      auto

Now become super user in a fresh and clean environment and send control sequence.

% exec sudo env -i bash -l
$ echo 'level disengaged' >/proc/acpi/ibm/fan 
bash: echo: write error: Invalid argument

What did I miss?

Thanks for suggests.

share|improve this question
    
On thinkwiki.org there are detailed instructions –  Floyd Jul 29 '12 at 5:59
    
@Floyd this seems relevant. –  carestad Nov 1 '12 at 0:03

1 Answer 1

Fan control is disabled at kernel driver level. It is enabled with the fan_control=1 option to the thinkpad_acpi module.

% sudo env -i bash -l
$ echo -e "\noptions thinkpad_acpi fan_control=1" >>/etc/modprobe.d/thinkpad_acpi.conf
$ modprobe -c | grep ^options | grep thinkpad_acpi
options thinkpad_acpi fan_control=1
$ modprobe -r thinkpad_acpi
$ modprobe thinkpad_acpi

For detailed information see http://ibm-acpi.sourceforge.net/README

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.