Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS Ul30vt with an intel/nvidia hybrid graphics card. I can get the intel driver to load just fine, but I am struggling to get the nvidia graphics card loaded. I have tried a number of different solutions including using the driver from ubuntu restricted drivers and from the nvidia website. I will describe my current situation though and see if that is enough information. Let me know if more in needed.

Currently when I run

jockey-text --list | grep nvidia

it returns the following

kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)

Also I can run

modinfo nvidia_current

and I see the following

filename:       /lib/modules/3.0.0-16-generic/updates/dkms/nvidia_current.ko
alias:          char-major-195-*
version:        295.20
supported:      external
license:        NVIDIA
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:
vermagic:       3.0.0-16-generic SMP mod_unload modversions 686
parm:           NVreg_EnableVia4x:int
parm:           NVreg_EnableALiAGP:int
parm:           NVreg_ReqAGPRate:int
parm:           NVreg_EnableAGPSBA:int
parm:           NVreg_EnableAGPFW:int
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_RemapLimit:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UseVBios:int
parm:           NVreg_RMEdgeIntrCheck:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_NvAGP:int

My xorg.conf looks like

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen1" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "record"
    Load  "dri"
    Load  "glx"
    Load  "extmod"
    Load  "dbe"
    Load  "dri2"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "DRI"                   # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "Shadow"                # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "VideoKey"              # <i>
        #Option     "WrappedFB"             # [<bool>]
        #Option     "GLXVBlank"             # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "PageFlip"              # [<bool>]
    Identifier  "Card1"
    Driver      "nvidia"
    BusID       "PCI:1:0:0"
EndSection


Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

This configuration currently fails (if I change it to use Screen0 with the intel driver I can get into lightdm just fine). When I have Screen1/nvidia selected though I get the following error

[   175.767] 
X.Org X Server 1.10.4
Release Date: 2011-08-19
[   175.767] X Protocol Version 11, Revision 0
[   175.767] Build Operating System: Linux 2.6.24-29-server i686 Ubuntu
[   175.767] Current Operating System: Linux ubuntu 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:49:42 UTC 2012 i686
[   175.767] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=8E2C55032C54E82B loop=/ubuntu/disks/root.disk ro quiet splash vt.handoff=7
[   175.767] Build Date: 19 October 2011  05:09:41AM
[   175.767] xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support) 
[   175.767] Current version of pixman: 0.22.2
[   175.767]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   175.767] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   175.767] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 18 09:36:25 2012
[   175.767] (==) Using config file: "/etc/X11/xorg.conf"
[   175.770] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   175.771] (==) ServerLayout "X.org Configured"
[   175.771] (**) |-->Screen "Screen1" (0)
[   175.771] (**) |   |-->Monitor "Monitor1"
[   175.771] (**) |   |-->Device "Card1"
[   175.771] (**) |-->Input Device "Mouse0"
[   175.771] (**) |-->Input Device "Keyboard0"
[   175.771] (==) Automatically adding devices
[   175.771] (==) Automatically enabling devices
[   175.772] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   175.772]    Entry deleted from font path.
[   175.772] (**) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins,
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
[   175.772] (**) ModulePath set to "/usr/lib/xorg/modules"
[   175.772] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   175.772] (WW) Disabling Mouse0
[   175.772] (WW) Disabling Keyboard0
[   175.772] (II) Loader magic: 0x823ada0
[   175.772] (II) Module ABI versions:
[   175.772]    X.Org ANSI C Emulation: 0.4
[   175.772]    X.Org Video Driver: 10.0
[   175.772]    X.Org XInput driver : 12.3
[   175.772]    X.Org Server Extension : 5.0
[   175.773] (--) PCI:*(0:0:2:0) 8086:2a42:1043:1af2 rev 7, Mem @ 0xfcc00000/4194304, 0xd0000000/268435456, I/O @ 0x0000cc00/8
[   175.773] (--) PCI: (0:1:0:0) 10de:0a74:1043:1af2 rev 162, Mem @ 0xfd000000/16777216, 0xe0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000dc00/128, BIOS @ 0x????????/524288
[   175.773] (II) Open ACPI successful (/var/run/acpid.socket)
[   175.773] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[   175.773] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[   175.773] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   175.773] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[   175.773] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[   175.773] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[   175.773] (II) LoadModule: "record"
[   175.774] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   175.774] (II) Module record: vendor="X.Org Foundation"
[   175.774]    compiled for 1.10.4, module version = 1.13.0
[   175.774]    Module class: X.Org Server Extension
[   175.774]    ABI class: X.Org Server Extension, version 5.0
[   175.774] (II) Loading extension RECORD
[   175.774] (II) LoadModule: "dri"
[   175.774] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   175.775] (II) Module dri: vendor="X.Org Foundation"
[   175.775]    compiled for 1.10.4, module version = 1.0.0
[   175.775]    ABI class: X.Org Server Extension, version 5.0
[   175.775] (II) Loading extension XFree86-DRI
[   175.775] (II) LoadModule: "glx"
[   175.775] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   175.775] (II) Module glx: vendor="X.Org Foundation"
[   175.775]    compiled for 1.10.4, module version = 1.0.0
[   175.775]    ABI class: X.Org Server Extension, version 5.0
[   175.775] (==) AIGLX enabled
[   175.775] (II) Loading extension GLX
[   175.775] (II) LoadModule: "extmod"
[   175.775] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   175.776] (II) Module extmod: vendor="X.Org Foundation"
[   175.776]    compiled for 1.10.4, module version = 1.0.0
[   175.776]    Module class: X.Org Server Extension
[   175.776]    ABI class: X.Org Server Extension, version 5.0
[   175.776] (II) Loading extension MIT-SCREEN-SAVER
[   175.776] (II) Loading extension XFree86-VidModeExtension
[   175.776] (II) Loading extension XFree86-DGA
[   175.776] (II) Loading extension DPMS
[   175.776] (II) Loading extension XVideo
[   175.776] (II) Loading extension XVideo-MotionCompensation
[   175.776] (II) Loading extension X-Resource
[   175.776] (II) LoadModule: "dbe"
[   175.776] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   175.776] (II) Module dbe: vendor="X.Org Foundation"
[   175.776]    compiled for 1.10.4, module version = 1.0.0
[   175.776]    Module class: X.Org Server Extension
[   175.776]    ABI class: X.Org Server Extension, version 5.0
[   175.776] (II) Loading extension DOUBLE-BUFFER
[   175.776] (II) LoadModule: "dri2"
[   175.776] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   175.777] (II) Module dri2: vendor="X.Org Foundation"
[   175.777]    compiled for 1.10.4, module version = 1.2.0
[   175.777]    ABI class: X.Org Server Extension, version 5.0
[   175.777] (II) Loading extension DRI2
[   175.777] (II) LoadModule: "nvidia"
[   175.777] (WW) Warning, couldn't open module nvidia
[   175.777] (II) UnloadModule: "nvidia"
[   175.777] (II) Unloading nvidia
[   175.777] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   175.777] (EE) No drivers available.
[   175.777] 
Fatal server error:
[   175.777] no screens found
[   175.777] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   175.777] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   175.777] 

I have tried typing in "nvidia_current" in the xorg.conf where it is looking for device name, but then it just fails and says it cannot find the "nvidiacurrent" module.

Essentially I am not sure what I need to put in the xorg.conf to point to the nvidia_current module that my system knows is there.

Thanks for any help and if any more information is needed.

share|improve this question
    
Does your graphic card has the Optimus chip? –  LnxSlck Mar 18 '12 at 14:21
    
I don't believe it does. It is the NVIDIA 300m –  Eric LaForce Mar 18 '12 at 17:34

4 Answers 4

Try regenerating the xorg.conf to test if it solves your issues.
First move current one to xorg.conf.old and then execute sudo nvidia-xconfig to regenerate it.

I also recommend you to run (before the above) sudo dpkg-reconfigure nvidia-current to make sure the driver is well configured.

share|improve this answer
    
sudo nvidia-xconfig is one of the first things I tried. It creates a similar setup to what I have now. I don't mind trying again, but I did a sudo apt-get remove --purge nvidia* at one point though and I no longer have nvidia-xconfig. Do you know what package I can install so that I get it back? –  Eric LaForce Mar 18 '12 at 17:36
    
It's part of nvidia-current. However, if you already tried that then I'm not sure it is the direction. –  yossile Mar 18 '12 at 18:03

This laptop (Asus UL30VT) is not an Optimus model although it has hybrid graphics. IIRC, it has a hardware mux that can be controlled through software (BIOS?).

Try:

  1. Remove the /etc/X11/xorg.conf file, setting should be detected automatically
  2. Reinstall nvidia-current: sudo apt-get install --reinstall nvidia-current
  3. Reboot into your BIOS and check for an option to force the use of an integrated or discrete card
  4. Boot Ubuntu
  5. Check whether the nvidia card is in use (log file is at /var/log/Xorg.0.log)
share|improve this answer
    
Unfortunately there is no option in the BIOS. I even tried upgrading but no luck. –  Eric LaForce Mar 19 '12 at 0:22

An old question, but still without answer - hope this helps someone.

Make sure you have headers for your kernel installed - without this one, you will not be able to build nvidia module.

sudo apt-get install linux-headers-`uname -r`

Then, run

sudo dpkg-reconfigure nvidia-current

After all, run

sudo nvidia-xconfig

or restore your original xorg.conf.

share|improve this answer

Updating the headers of the kernel did the trick! I had tried to run sudo nvidia-xconfig without luck but a fresh install of nvidia plus updating the headers fixed the generation of the file. See commands for a fresh update below:

sudo apt-get --purge remove nvdia-*  

sudo apt-get install nvidia-current 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.