Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed the KDE Kubuntu desktop but after somehow working with i decided to use pure GNOME Ubuntu desktop again.I remove Kubuntu desktop and its packages completely but Kubuntu background image still running at time of booting the system and shutting down it. I tried the steps below at terminal , it made the shutting down background image correct but still the background image of booting time is kubuntu image.

sudo update-alternatives --set default.plymouth /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth

How could i change this image to the default Ubuntu image too?

share|improve this question
3  
did you run update-initramfs -u after that ? –  warl0ck Mar 19 '12 at 23:49
1  
Thanks a lot Aaron Lewis,well down , it worked well. –  Pezhman Karimeh Mar 21 '12 at 21:31

2 Answers 2

Where does the Plymouth theme come from?

There are a number of plymouth themes available from the Ubuntu repositories. When you install plain Ubuntu desktop, the package "ubuntu-desktop" will install the package "plymouth-theme-ubuntu-logo" which is the plain Ubuntu plymouth theme.

When you install Kubuntu, the package "kubuntu-desktop" will install the plymouth theme "plymouth-theme-kubuntu-logo".

If you have more than one plymouth theme installed, you can choose your preferred one with:

sudo update-alternatives --config default.plymouth 

Note that this applies to the plymouth graphical theme. Plymouth also has a text theme which should only show if graphics are unavailable. The same applies, but the package names are a bit different and the update-alternatives entry is "text.plymouth" rather than "default.plymouth".

How do I make it take effect at boot? / Why do I only see my new choice at shutdown?

For the bootup sequence, plymouth needs to load before the root file system is mounted, therefore it needs to be present in initramfs (the initial ram filesystem).

The reason you are seeing the correct splash at shutdown is that you have update plymouth's configuration successfully, but the same configuration hasn't been placed into the initramfs.

To update the initramfs, you use the command:

sudo update-initramfs -u
share|improve this answer

The correct way to change your plymouth back to default is as follows:

In a terminal (Ctrl+Alt+T), type

sudo update-alternatives --config default.plymouth

Key in the number associated with the Ubuntu default plymouth from the options that appear

Then type

sudo update-initramfs -u

Then reboot

sudo reboot

Note: What to do if the Ubuntu default Plymouth is not in the options presented:

You can copy the appropriate files from the Ubuntu live CD as follows:

  • Copy the Ubuntu default folder to /lib/plymouth/themes.

  • Copy the file splash into /etc/initramfs-tools/conf.d (Optional, for better buffer)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.