Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to run 32bit sun-jdk on my 64bit ubuntu. I downloaded JDK and when run I get

java.lang.UnsatisfiedLinkError: /opt/java/32/jdk1.6.0_31/jre/lib/i386/xawt/libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
    at java.lang.Runtime.load0(Runtime.java:770)
    at java.lang.System.load(System.java:1003)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1724)
    at java.lang.Runtime.loadLibrary0(Runtime.java:823)
    at java.lang.System.loadLibrary(System.java:1028)
    at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoader.java:38)
    at sun.awt.DebugHelper.<clinit>(DebugHelper.java:29)
    at java.awt.Component.<clinit>(Component.java:566)
    at com.mucommander.Launcher.main(Launcher.java:466)
Exception in thread "main" java.lang.NullPointerException
    at com.mucommander.text.Translator.get(Translator.java:258)
    at com.mucommander.Launcher.main(Launcher.java:612)

I installed libXtst6 and libext6:i386 to no avail.

Any ideas?

share|improve this question
    
This setup was needed for my previous workplace for Juniper VPN and I ended up using chrooted x86 environment –  rojanu Jun 22 '12 at 7:35

4 Answers 4

I had a similar problem with missing libxtst.so. I solved it by running the following command in a terminal:

sudo apt-get install libxtst6:i386

Hope it helps!

share|improve this answer

Also

sudo apt-get install libxi6

The complete command is:

sudo apt-get install libxi6 libxtst6 libxrender1
share|improve this answer
    
Please note that it's advisable to run sudo apt-get update before installing or updating software from the command-line. sudo apt-get update fetches updated information about what packages are available in what versions from where. –  Eliah Kagan Aug 14 '12 at 20:51

Have you tried installing ia32-libs Install ia32-libs? I am a java-android developer, and I need to install this when I make a fresh installation of android-sdk (which is 32 bit) in my 64 bit Ubuntu.
I tried this with Ubuntu 12.04 and now on 12.10.

share|improve this answer

You have run into your downloaded binary depending on different libraries than those you have installed.

If you just need a Java installation, and not a Sun Java installation, do a sudo apt-get openjdk-6-jdk instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.