Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed ntop on my machine and I need to specify which network interface it should listen on. When I go to Admin -> Configure -> Startup Options in the web interface it says:

You cannot set the capture interface: missing privileges.

You need to start ntop with super-user privileges [-u]

How do I add the -u to the service startup?

share|improve this question
    
It's generally a poor idea to run services as root. Do you know if ntop drops its superuser privileges after startup? –  Nick Pascucci Nov 5 '10 at 0:16

2 Answers 2

There's page on this in the Ubuntu community docs: https://help.ubuntu.com/community/Ntop

It says:

When first installing & configuring the ntop application you need to set an admin password.

sudo ntop --set-admin-password
share|improve this answer
    
I did that when I installed ntop. That sets the website admin login password. –  Andy May Nov 4 '10 at 23:09
    
Ah, sorry about that. It may be that that setting can't be changed through the Web interface. I just tried it on my machine, and I could switch the interface by specifying it at startup: sudo ntop -u ntop -d -i ethX –  jasonbrooks Nov 5 '10 at 16:29

The user is defined at /var/lib/ntop/init.cfg, I am not sure it's safe to change it since it was packaged to run with ntop, it was expected to work.

share|improve this answer
    
Right now it has USER="ntop". If I change this value to anything else it errors saying it cannot run as that user. –  Andy May Nov 4 '10 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.