Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am fairly new to Ubuntu, the first time i ran it of the disk drive, all keys worked fine. However, now @=" M=0 J=1 etc. I can only get a few correct letters. I tried all keyboard and language setting I know of...this is rather annoying! If you can help me, thanks a lot!

share|improve this question
Can you please tell us your keyboard layout? – Vibhav Pant Mar 18 '12 at 3:45

if you hit CAPSLOCK + SHIFT + CTRL all at the same time it alters your keyboard settings.

Just hold all three again and its fixed. (also if other symbols are still wrong try repeating till its back to normal. the quotation marks also switch up)

share|improve this answer

It sounds to me you have your regional settings wrong, a UK keyboard has the @ near the enter key, but a US keyboard has a " near to the enter key on the same key if you get what I mean.

Different regions have different layouts

share|improve this answer

Press FN+the numlock button. In my case, It's FN+F11

share|improve this answer

Its most probably because of your keyboard layout. Just change the keyboard language (located at top-right corner and represented by En) from the English(UK) to English(US).

It worked for me :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.